hdu 2412 Party at Hali-Bula(树形DP)

Party at Hali-Bula

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1860    Accepted Submission(s): 649


Problem Description
Dear Contestant,

I'm going to have a party at my villa at Hali-Bula to celebrate my retirement from BCM. I wish I could invite all my co-workers, but imagine how an employee can enjoy a party when he finds his boss among the guests! So, I decide not to invite both an employee and his/her boss. The organizational hierarchy at BCM is such that nobody has more than one boss, and there is one and only one employee with no boss at all (the Big Boss)! Can I ask you to please write a program to determine the maximum number of guests so that no employee is invited when his/her boss is invited too? I've attached the list of employees and the organizational hierarchy of BCM.

Best,
--Brian Bennett

P.S. I would be very grateful if your program can indicate whether the list of people is uniquely determined if I choose to invite the maximum number of guests with that condition.
 

Input
The input consists of multiple test cases. Each test case is started with a line containing an integer n (1 ≤ n ≤ 200), the number of BCM employees. The next line contains the name of the Big Boss only. Each of the following n-1 lines contains the name of an employee together with the name of his/her boss. All names are strings of at least one and at most 100 letters and are separated by blanks. The last line of each test case contains a single 0.
 

Output
For each test case, write a single line containing a number indicating the maximum number of guests that can be invited according to the required condition, and a word Yes or No, depending on whether the list of guests is unique in that case.
 

Sample Input
  
  
6 Jason Jack Jason Joe Jack Jill Jason John Jack Jim Jill 2 Ming Cho Ming 0
 

Sample Output
  
  
4 Yes 1 No
 

Source
 
1520的加强版,比1520多增加了判断是否唯一,刚开始我竟然傻傻的判断是否有dp[i][0]==dp[i][1],其实儿子去与不去都一样,但是父亲去了,儿子就不能去了,就成了唯一的啦,再用一个dps[maxn][2]标记一下,是否值唯一,
1,如果儿子去不去都一样,父亲也不去,就有多种方案,;
2,如果儿子不去有多种方案,父亲去也有多种方案;
3,如果儿子不去有多种方案,并且,不去的人数大于去的,父亲不去也有多种方案,;
4,如果儿子去有多种方案,并且,取得人数大于不去的,父亲不去也有多种方案;、

代码:
#include <iostream>
#include <cstdio>
#include <cstring>
#include <string>
#include <algorithm>
#include <map>
#include <vector>
using namespace std;
const int maxn=200+100;
int t;
int dp[maxn][2];
int dps[maxn][2];
vector<int>son[maxn];
map<string,int> mp;
void dfs(int u)
{
    dp[u][1]=1;
    for(int i=0;i<son[u].size();i++)
    {
        int v=son[u][i];
        dfs(v);
        dp[u][0]+=max(dp[v][0],dp[v][1]);
        dp[u][1]+=dp[v][0];
        if(dp[v][0]>dp[v][1]&&dps[v][0]==0)//如果儿子不去有多种方案,并且,不去的人数大于去的,父亲不去也有多种方案,
        dps[u][0]=0;
        if(dp[v][0]<dp[v][1]&&dps[v][1]==0)//如果儿子去有多种方案,并且,取得人数大于不去的,父亲不去也有多种方案
        dps[u][0]=0;
        if(dp[v][0]==dp[v][1])//如果儿子去不去都一样,父亲也不去,就有多种方案,
        dps[u][0]=0;
        if(dps[v][0]==0)//如果儿子不去有多种方案,父亲去也有多种方案
        dps[u][1]=0;
    }
    return;
}
int main()
{
    int n;
    while(~scanf("%d",&n))
    {
        if(n==0)
        break;
        for(int i=0;i<=n;i++)
        son[i].clear();
        mp.clear();
        memset(dp,0,sizeof(dp));
        memset(dps,1,sizeof(dps));
        t=1;
        string s,s1;
        int x,y;
        cin>>s;
        mp[s]=t++;
        for(int i=1;i<n;i++)
        {
           cin>>s>>s1;
           if(!mp[s])
           {
               mp[s]=t++;
           }
           if(!mp[s1])
           {
               mp[s1]=t++;
           }
           x=mp[s];
           y=mp[s1];
           son[y].push_back(x);
        }
        dfs(1);
        if(dp[1][0]>dp[1][1]&&dps[1][0])
        {
            printf("%d Yes\n",dp[1][0]);
        }
        else if(dp[1][0]<dp[1][1]&&dps[1][1])
        {
            printf("%d Yes\n",dp[1][1]);
        }
        else
        {
            printf("%d No\n",max(dp[1][0],dp[1][1]));
        }
    }
    return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
【1】项目代码完整且功能都验证ok,确保稳定可靠运行后才上传。欢迎下载使用!在使用过程中,如有问题或建议,请及时私信沟通,帮助解答。 【2】项目主要针对各个计算机相关专业,包括计科、信息安全、数据科学与大数据技术、人工智能、通信、物联网等领域的在校学生、专业教师或企业员工使用。 【3】项目具有较高的学习借鉴价值,不仅适用于小白学习入门进阶。也可作为毕设项目、课程设计、大作业、初期项目立项演示等。 【4】如果基础还行,或热爱钻研,可基于此项目进行二次开发,DIY其他不同功能,欢迎交流学习。 【注意】 项目下载解压后,项目名字和项目路径不要用中文,否则可能会出现解析不了的错误,建议解压重命名为英文名字后再运行!有问题私信沟通,祝顺利! 基于C语言实现智能决策的人机跳棋对战系统源码+报告+详细说明.zip基于C语言实现智能决策的人机跳棋对战系统源码+报告+详细说明.zip基于C语言实现智能决策的人机跳棋对战系统源码+报告+详细说明.zip基于C语言实现智能决策的人机跳棋对战系统源码+报告+详细说明.zip基于C语言实现智能决策的人机跳棋对战系统源码+报告+详细说明.zip基于C语言实现智能决策的人机跳棋对战系统源码+报告+详细说明.zip基于C语言实现智能决策的人机跳棋对战系统源码+报告+详细说明.zip基于C语言实现智能决策的人机跳棋对战系统源码+报告+详细说明.zip基于C语言实现智能决策的人机跳棋对战系统源码+报告+详细说明.zip基于C语言实现智能决策的人机跳棋对战系统源码+报告+详细说明.zip基于C语言实现智能决策的人机跳棋对战系统源码+报告+详细说明.zip基于C语言实现智能决策的人机跳棋对战系统源码+报告+详细说明.zip基于C语言实现智能决策的人机跳棋对战系统源码+报告+详细说明.zip
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值