hdu 4737 A Bit Fun(2013 成都网络赛)

A Bit Fun

                                                  Time Limit: 5000/2500 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
                                                                       Total Submission(s): 2089    Accepted Submission(s): 1040


Problem Description
There are n numbers in a array, as a 0, a 1 ... , a n-1, and another number m. We define a function f(i, j) = a i|a i+1|a i+2| ... | a j . Where "|" is the bit-OR operation. (i <= j)
The problem is really simple: please count the number of different pairs of (i, j) where f(i, j) < m.
 

Input
The first line has a number T (T <= 50) , indicating the number of test cases.
For each test case, first line contains two numbers n and m.(1 <= n <= 100000, 1 <= m <= 2 30) Then n numbers come in the second line which is the array a, where 1 <= a i <= 2 30.
 

Output
For every case, you should output "Case #t: " at first, without quotes. The  t is the case number starting from 1.
Then follows the answer.
 

Sample Input
  
  
2 3 6 1 3 5 2 4 5 4
 

Sample Output
  
  
Case #1: 4 Case #2: 0
 

用个数组记录下各位出现的次数,就可以实现在一段区间或的值中减去一个元素。

代码:
#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>
#include <queue>
#include <vector>
#include <string>
#include <map>
#include <cstdlib>
#include <ctime>
using namespace std;
const int maxn=100000+1000;
int a[maxn];
int h[100];
int n,m;
void add(int x)
{
    int cur=0;
    while(x)
    {
        h[cur++]+=(x%2);
        x=x/2;
    }
}
void del(int x)
{
    int cur=0;
    while(x)
    {
        h[cur++]-=(x%2);
        x=x/2;
    }
}
int re()
{
    int ans=0;
    for(int i=0; i<35; i++)
    {
        if(h[i]>0)
            ans+=(1<<i);
    }
    return ans;
}
int main()
{
    int t,ca=1;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d%d",&n,&m);
        memset(h,0,sizeof(h));
        for(int i=0; i<n; i++)
            scanf("%d",&a[i]);
        int temp=0;
        long long ans=0;
        int cur=0;
        for(int i=0; i<n; i++)
        {
            cur=max(i,cur);
            while((temp|a[cur])<m&&cur<n)
            {
                temp=(temp|a[cur]);
                add(a[cur]);
                cur++;
            }
            if(cur>i)
            {
                ans+=(cur-i);
                del(a[i]);
                temp=re();
            }
        }
        printf("Case #%d: ",ca++);
        cout<<ans<<endl;
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值