hdu 5101 Select(Bestcoder Round #17)

Select

                                                   Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
                                                                   Total Submission(s): 285    Accepted Submission(s): 85


Problem Description
One day, Dudu, the most clever boy, heard of ACM/ICPC, which is a very interesting game. He wants to take part in the game. But as we all know, you can't get good result without teammates.
So, he needs to select two classmates as his teammates. 
In this game, the IQ is very important, if you have low IQ you will WanTuo. Dudu's IQ is a given number k. We use an integer v[i] to represent the IQ of the ith classmate. 
The sum of new two teammates' IQ must more than Dudu's IQ.
For some reason, Dudu don't want the two teammates comes from the same class.
Now, give you the status of classes, can you tell Dudu how many ways there are.
 

Input
There is a number T shows there are T test cases below. ( T20 )
For each test case , the first line contains two integers, n and k, which means the number of class and the IQ of Dudu. n (  0n1000  ), k(  0k<231  ).
Then, there are n classes below, for each class, the first line contains an integer m, which means the number of the classmates in this class, and for next m lines, each line contains an integer v[i], which means there is a person whose iq is v[i] in this class. m(  0m100  ), v[i](  0v[i]<231  )
 

Output
For each test case, output a single integer.
 

Sample Input
  
  
1 3 1 1 2 1 2 2 1 1
 

Sample Output
  
  
5
 

    一个人要选两名队员,两名队员的IQ之和要大于他的,另两名队员不能在一个班级。

   这题的二分思路还是很容易想出来的,总人数1000*100,时限为2s,复杂度肯定为nlog(n),又因为是找比一个数大的,很符合二分的性质。

     官方题解:
  答案=从所有数中选择的两个加和大于k的数的方案数-在同一个集合中选择的两个加和大于k的数的方案数
而对于同一个集合中选择的两个加和大于k的方案数是可以直接排序然后利用单调性快速统计出来的。
代码:
#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <vector>
using namespace std;
const int maxn=100000+100;
int a[maxn];
int map[1010][110];
int v[1010];
int cur;
int finda(int x)//在大的区间二分查找
{
    int l=0;
    int r=cur-1;
    if(x>=a[r])
    return cur;
    while(l<r)
    {
        int m=(l+r)>>1;
        if(a[m]<=x)
        l=m+1;
        else
        r=m;
    }
    return l;
}
int find(int p,int x)//在小区间二分查找
{
    if(x>=map[p][v[p]-1])
    return v[p];
    int l=0;
    int r=v[p]-1;
    while(l<r)
    {
        int m=(l+r)>>1;
        if(map[p][m]>x)
        r=m;
        else
        l=m+1;
    }
    return l;
}
int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        int n,k,m;
        scanf("%d%d",&n,&k);
        cur=0;
        for(int i=0;i<n;i++)
        {
            scanf("%d",&v[i]);
            m=v[i];
            for(int j=0;j<m;j++)
            {
                scanf("%d",&map[i][j]);
                a[cur++]=map[i][j];
            }
            sort(map[i],map[i]+m);
        }
        sort(a,a+cur);
        long long ans=0;
        for(int i=0;i<n;i++)
        {
            for(int j=0;j<v[i];j++)
            {
                int to=k-map[i][j];
                int temp=cur-finda(to);
                int temp2=v[i]-find(i,to);
                ans+=(temp-temp2);
            }
        }
        printf("%I64d\n",ans/2);
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值