hdu 5100 Chessboard(Bestcoder Round #17)

Chessboard

                                      Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
                                                                    Total Submission(s): 126    Accepted Submission(s): 76


Problem Description
Consider the problem of tiling an n×n chessboard by polyomino pieces that are k×1 in size; Every one of the k pieces of each polyomino tile must align exactly with one of the chessboard squares. Your task is to figure out the maximum number of chessboard squares tiled.
 

Input
There are multiple test cases in the input file.
First line contain the number of cases T ( T10000 ). 
In the next T lines contain T cases , Each case has two integers n and k. ( 1n,k100 )
 

Output
Print the maximum number of chessboard squares tiled.
 

Sample Input
  
  
2 6 3 5 3
 

Sample Output
  
  
36 24
 

官方题解:
首先,若
     
     
      
      n<k
     
     ,则棋盘连一个
     
     
      
      1×k
     
     的矩形都放不下,输出
     
     
      
      0
     
     。
我们只需要考虑
     
     
      
      nk
     
     的情况。将棋盘类似于黑白染色,按
     
     
      
      (i+j)
     
     
     
     
      
      k
     
     划分等价类,给每个格子标一个号。
标号之后,会注意到每条从左下到右上的斜线数字都是相同的,那么对于
     
     
      
      s×s
     
     的格子,其内部数字有且恰好有
     
     
      
      2s1
     
     种,所以当
     
     
      
      s<=k2
     
     的时候,内部数字有
     
     
      
      floor(k2)21<k
     
     种,所以不能有更佳的方案。
从而证明最优的方案一定是仅剩下一个
     
     
      
      s×s
     
     的正方形区域没有被覆盖到,其中
     
     
      
      sk2
     
     。
而令
     
     
      
      l=n
     
      mod 
     
     
      
      k
     
     之后,根据
     
     
      
      l
     
     大小的不同,可以构造出中心为
     
     
      
      l×l
     
     
     
     
      
      (kl)×(kl)
     
     的风车形图案,又通过上面证明这个
     
     
      
      l
     
     (或
     
     
      
      kl
     
     )就是之前的
     
     
      
      s
     
     ,所以是最优的。
所以令
     
     
      
      l=n
     
      mod 
     
     
      
      k
     
     ,如果
     
     
      
      lk2
     
     ,最多可覆盖的格子数即为
     
     
      
      n2l2
     
     ,否则为
     
     
      
      n2(kl)2
     
     ,显然这样的方案是可以构造出来的(风车形)。
代码:
#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
int main()
{
    int n,k,t;
    scanf("%d",&t);
    while(t--)
    {
        int ans=0;
        scanf("%d%d",&n,&k);
        if(n >= k)
        {
            int r = n % k;
            if(r <= k/2)
            {
                ans = n*n - r*r;
            }
            else
            {
                ans = n*n - (k-r)*(k-r);
            }
        }
        else
        {
            ans = 0;
        }
        printf("%d\n",ans);
    }
    return 0;
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值