POJ 2923 Relocation(状压+背包)

Relocation
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 2340 Accepted: 965

Description

Emma and Eric are moving to their new house they bought after returning from their honeymoon. Fortunately, they have a few friends helping them relocate. To move the furniture, they only have two compact cars, which complicates everything a bit. Since the furniture does not fit into the cars, Eric wants to put them on top of the cars. However, both cars only support a certain weight on their roof, so they will have to do several trips to transport everything. The schedule for the move is planed like this:

  1. At their old place, they will put furniture on both cars.
  2. Then, they will drive to their new place with the two cars and carry the furniture upstairs.
  3. Finally, everybody will return to their old place and the process continues until everything is moved to the new place.

Note, that the group is always staying together so that they can have more fun and nobody feels lonely. Since the distance between the houses is quite large, Eric wants to make as few trips as possible.

Given the weights wi of each individual piece of furniture and the capacities C1 and C2 of the two cars, how many trips to the new house does the party have to make to move all the furniture? If a car has capacity C, the sum of the weights of all the furniture it loads for one trip can be at most C.

Input

The first line contains the number of scenarios. Each scenario consists of one line containing three numbers nC1 and C2C1 and C2 are the capacities of the cars (1 ≤ Ci ≤ 100) and n is the number of pieces of furniture (1 ≤ n ≤ 10). The following line will contain n integers w1, …, wn, the weights of the furniture (1 ≤ wi ≤ 100). It is guaranteed that each piece of furniture can be loaded by at least one of the two cars.

Output

The output for every scenario begins with a line containing “Scenario #i:”, where i is the number of the scenario starting at 1. Then print a single line with the number of trips to the new house they have to make to move all the furniture. Terminate each scenario with a blank line.

Sample Input

2
6 12 13
3 9 13 3 10 11
7 1 100
1 2 33 50 50 67 98

Sample Output

Scenario #1:
2

Scenario #2:
3

Source

TUD Programming Contest 2006, Darmstadt, Germany

两辆车运家具,先把所有能一次运走的家具组合用状压找出来,后用背包在所有的组合找最少的运的次数


代码:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
const int maxn=5000;
const int inf=0x7ffffff;
int dp[maxn],vis[maxn],a[maxn];
int w[maxn];
int n,c1,c2;
bool check(int x)//判断当前状态下是否能够一次运完
{
    int sum=0;
    memset(vis,0,sizeof(vis));
    vis[0]=1;
    for(int i=0;i<n;i++)
    {
        if(x&(1<<i))
        {
           sum+=w[i];
           for(int j=c1-w[i];j>=0;j--)//01背包
           {
               if(vis[j])
               vis[j+w[i]]=1;
           }
        }
    }
    for(int i=c1;i>=0;i--)
    {
        if(vis[i]&&sum-i<=c2)
        return true;
    }
    return false;
}
int main()
{
    int t,sign=0,count=1;
    scanf("%d",&t);
    while(t--)
    {
        if(sign)
        printf("\n");
        else
        sign=1;
        scanf("%d%d%d",&n,&c1,&c2);
        for(int i=0;i<n;i++)
        {
            scanf("%d",&w[i]);
        }
        int cur=(1<<n)-1;
        int cnt=0;
        //遍历所有的状态,将所有可以一次运完的储存在a数组内
        for(int i=0;i<=cur;i++)
        {
            if(check(i))
            a[cnt++]=i;
        }
        for(int i=0;i<maxn;i++)
        dp[i]=inf;
        dp[0]=0;
        for(int i=0;i<cnt;i++)//背包
        {
            for(int j=cur-a[i];j>=0;j--)
            {
                dp[j|a[i]]=min(dp[j|a[i]],dp[j]+1);
            }
        }
        printf("Scenario #%d:\n%d\n",count++,dp[cur]);
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值