1033. To Fill or Not to Fill

1033. To Fill or Not to Fill (25)

时间限制
10 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
ZHANG, Guochuan

With highways available, driving a car from Hangzhou to any other city is easy. But since the tank capacity of a car is limited, we have to find gas stations on the way from time to time. Different gas station may give different price. You are asked to carefully design the cheapest route to go.

Input Specification:

Each input file contains one test case. For each case, the first line contains 4 positive numbers: Cmax (<= 100), the maximum capacity of the tank; D (<=30000), the distance between Hangzhou and the destination city; Davg (<=20), the average distance per unit gas that the car can run; and N (<= 500), the total number of gas stations. Then N lines follow, each contains a pair of non-negative numbers: Pi, the unit gas price, and Di (<=D), the distance between this station and Hangzhou, for i=1,...N. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the cheapest price in a line, accurate up to 2 decimal places. It is assumed that the tank is empty at the beginning. If it is impossible to reach the destination, print "The maximum travel distance = X" where X is the maximum possible distance the car can run, accurate up to 2 decimal places.

Sample Input 1:
50 1300 12 8
6.00 1250
7.00 600
7.00 150
7.10 0
7.20 200
7.50 400
7.30 1000
6.85 300
Sample Output 1:
749.17
Sample Input 2:
50 1300 12 2
7.10 0
7.00 600
Sample Output 2:
The maximum travel distance = 1200.00
考查:最优问题
#include<stdio.h>
#include<algorithm>
#include<vector>
using namespace std;

struct Station
{
	double price;
	double location;
};


bool cmp(Station A, Station B)
{
	return A.location < B.location;
}

vector<Station> v;

int main()
{
	freopen("F://temp/input.txt", "r", stdin);
	int c, d, d_avg, n;
	scanf("%d%d%d%d", &c, &d, &d_avg, &n);
	for(int i = 0; i < n; i ++)
	{
		Station tmp;
		scanf("%lf %lf", &tmp.price, &tmp.location);
		v.push_back(tmp);
	}
	
	Station tmp;
	tmp.location = d;
	tmp.price = 0;
	v.push_back(tmp);//写入起始位置
	
	sort(v.begin(), v.end(), cmp);
	double distance_full = c * d_avg;//满气走的路程
	
	for(int i = 0; i < v.size()-1; i ++)
	{
		//起点没有加油站 
		if(v[0].location > 0)
		{
			printf("The maximum travel distance = 0.00\n");
			return 0;
		}
		
		//两个加气站距离超过最大行驶 
		if(v[i+1].location - v[i].location > distance_full)
		{
			double max = v[i].location + distance_full;
			printf("The maximum travel distance = %.2lf\n", max);
			return 0;
		} 
	} 
	
	double remain = 0, money = 0, distance = 0;
	int station_now = 0, station_next;
	while(distance < d)
	{
		station_next = -1;
		//寻找下一个性价比高的加气站 
		for(int i = station_now + 1; i < v.size(); i ++)
		{
			if(v[i].location - v[station_now].location > distance_full)
				break;
			else if(v[i].price <= v[station_now].price)
			{
				station_next = i;
				break;
			}
		}
		
		//找到了更便宜的加气站 
		if(station_next != -1)
		{
			double dis_tmp = v[station_next].location - v[station_now].location;
			distance = v[station_next].location;
			if(remain > dis_tmp / d_avg)//如果可以当前的气可以开到加气站 
			{
				remain = remain - dis_tmp / d_avg;
				money = money;
			}
			else//如果当前的气不可以开到加气站 
			{
				money += (dis_tmp / d_avg - remain) * v[station_now].price;
				remain = 0;
			}
			station_now = station_next;
		}
		//没有找到,在当前汽车可以走到的加气站中选择价钱最便宜的 
		else 
		{
			double dis_tmp = v[station_now + 1].location - v[station_now].location;
			distance = v[station_now + 1].location;
			money += (c - remain) * v[station_now].price;
			remain = c - dis_tmp / d_avg;
			station_now ++;
		} 
	}
	
	printf("%.2lf\n", money);
	
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值