(hdu step 2.3.6)Game of Connections(大数:凸多边形的三角形划分)

在写题解之前给自己打一下广告哈~委屈。。抱歉了,希望大家多多支持我在CSDN的视频课程,地址如下:

http://edu.csdn.net/course/detail/209


题目:

         

Game of Connections

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 673 Accepted Submission(s): 443
 
Problem Description
This is a small but ancient game. You are supposed to write down the numbers 1, 2, 3, ... , 2n - 1, 2n consecutively in clockwise order on the ground to form a circle, and then, to draw some straight line segments to connect them into number pairs. Every number must be connected to exactly one another. And, no two segments are allowed to intersect.

It's still a simple game, isn't it? But after you've written down the 2n numbers, can you tell me in how many different ways can you connect the numbers into pairs? Life is harder, right?
 
Input
Each line of the input file will be a single positive number n, except the last line, which is a number -1. You may assume that 1 <= n <= 100.
 
Output
For each n, print in a single line the number of ways to connect the 2n numbers into pairs.
 
Sample Input
2
3
-1
 
Sample Output
2
5
 
 
Source
Asia 2004, Shanghai (Mainland China), Preliminary
 
Recommend
Eddy
 


题目分析:

             这一道题,读完题以后,抽象以下,其模型可以归结为“凸多边形的三角形划分。其中线段两两不相交”。而这一模型又可以使用卡特兰数来解决。

需要注意的是:catalans[20]就已经达到了6564120420。这已经超过了int的范围。catalans[99]的值为227508830794229349661819540395688853956041682601541047340。这已经超过了证书所能表示的范围,所以使用大数来处理


代码如下:

import java.math.BigInteger;
import java.util.Scanner;


public class Main {

	public static void main(String[] args) {
		BigInteger catalans[] = new BigInteger[101];
		
		catalans[1] = new BigInteger("1");
		
		BigInteger four = new BigInteger("4");
		BigInteger two = new BigInteger("2");
		BigInteger one = new BigInteger("1");
		
		int i;
		for(i = 2 ; i <= 100 ; ++i){//注意catalan[20]已经是6564120420了.所以需要用到大数
			//根绝catalans数的递推公式来求得每一项的catalan数
			catalans[i] = catalans[i-1].multiply(four.multiply(BigInteger.valueOf(i)).subtract(two)).divide(BigInteger.valueOf(i+1));
		}
		
		Scanner scanner = new Scanner(System.in);
		while(scanner.hasNext()){
			int n = scanner.nextInt();
			if(n == -1){
				return ;
			}
			
			System.out.println(catalans[n]);
		}
	}
}





评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

帅气的东哥

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值