(hdu step 6.1.2)Eddy's picture(在只给出二维坐标点的情况下,求让n个点连通的最小费用)

题目:

Eddy's picture

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 172 Accepted Submission(s): 126
 
Problem Description
Eddy begins to like painting pictures recently ,he is sure of himself to become a painter.Every day Eddy draws pictures in his small room, and he usually puts out his newest pictures to let his friends appreciate. but the result it can be imagined, the friends are not interested in his picture.Eddy feels very puzzled,in order to change all friends 's view to his technical of painting pictures ,so Eddy creates a problem for the his friends of you.
Problem descriptions as follows: Given you some coordinates pionts on a drawing paper, every point links with the ink with the straight line, causes all points finally to link in the same place. How many distants does your duty discover the shortest length which the ink draws?
 
Input
The first line contains 0 < n <= 100, the number of point. For each point, a line follows; each following line contains two real numbers indicating the (x,y) coordinates of the point. 

Input contains multiple test cases. Process to the end of file.
 
Output
Your program prints a single real number to two decimal places: the minimum total length of ink lines that can connect all the points. 
 
Sample Input
3
1.0 1.0
2.0 2.0
2.0 4.0
 
Sample Output
3.41
 
Author
eddy
 
 
Recommend
JGShining
 


题目分析:

               使用kruscal来求最小生成树,简单题。这道题和上一道题比较的特点就在于:

1)有一维坐标点变成二维坐标点。

struct Point{
double x;
double y;
}points[maxn];

2)点与点之间的距离不再直接给出,而需要你自己算。

edges[cnt++].weight = get_distance(points[i],points[j]);//这是点与点之间的距离不再是直接给出而是需要你自己算



代码如下:

/*
 * b.cpp
 *
 *  Created on: 2015年3月9日
 *      Author: Administrator
 */

#include <iostream>
#include <cstdio>
#include <cmath>
#include <algorithm>


using namespace std;

const int maxn = 101;

struct Point{
	double x;
	double y;
}points[maxn];

struct Edge{
	int begin;
	int end;
	double weight;
}edges[maxn*maxn];

int father[maxn];

int find(int a){
	if(a == father[a]){
		return a;
	}

	return father[a] = find(father[a]);
}



double kruscal(int count){
	int i;

	for(i = 1 ; i < maxn ; ++i){
		father[i] = i;
	}

	double sum = 0;

	for(i = 1 ; i <= count ; ++i){
		int fx = find(edges[i].begin);
		int fy = find(edges[i].end);

		if(fx != fy){
			father[fx] = fy;
			sum += edges[i].weight;
		}
	}

	return sum;
}

double get_distance(Point a,Point b){
	return sqrt(pow(b.x-a.x,2)+pow(b.y-a.y,2));
}

bool cmp(Edge a,Edge b){
	return a.weight < b.weight;
}

int main(){
	int n;
	while(scanf("%d",&n)!=EOF){
		int i;
		for(i = 1 ; i <= n ; ++i){
			scanf("%lf%lf",&points[i].x,&points[i].y);
		}

		int cnt = 1;
		int j;
		for(i = 1 ; i <= n ; ++i){//枚举所有能形成边的情况
			for(j = i+1 ; j <= n ; ++j){
				edges[cnt].begin = i;
				edges[cnt].end = j;
				edges[cnt++].weight = get_distance(points[i],points[j]);//这是点与点之间的距离不再是直接给出而是需要你自己算
			}
		}

		cnt -= 1;

		sort(edges+1,edges+1+cnt,cmp);

		printf("%.2lf\n",kruscal(cnt));

	}

	return 0;
}














  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

帅气的东哥

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值