(hdu step 6.3.3)Air Raid(最小路径覆盖:求用最少边把所有的顶点都覆盖)

题目:

Air Raid

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 124 Accepted Submission(s): 102
 
Problem Description
Consider a town where all the streets are one-way and each street leads from one intersection to another. It is also known that starting from an intersection and walking through town's streets you can never reach the same intersection i.e. the town's streets form no cycles.

With these assumptions your task is to write a program that finds the minimum number of paratroopers that can descend on the town and visit all the intersections of this town in such a way that more than one paratrooper visits no intersection. Each paratrooper lands at an intersection and can visit other intersections following the town streets. There are no restrictions about the starting intersection for each paratrooper.
 
Input
Your program should read sets of data. The first line of the input file contains the number of the data sets. Each data set specifies the structure of a town and has the format:

no_of_intersections
no_of_streets
S1 E1
S2 E2
......
Sno_of_streets Eno_of_streets

The first line of each data set contains a positive integer no_of_intersections (greater than 0 and less or equal to 120), which is the number of intersections in the town. The second line contains a positive integer no_of_streets, which is the number of streets in the town. The next no_of_streets lines, one for each street in the town, are randomly ordered and represent the town's streets. The line corresponding to street k (k <= no_of_streets) consists of two positive integers, separated by one blank: Sk (1 <= Sk <= no_of_intersections) - the number of the intersection that is the start of the street, and Ek (1 <= Ek <= no_of_intersections) - the number of the intersection that is the end of the street. Intersections are represented by integers from 1 to no_of_intersections.

There are no blank lines between consecutive sets of data. Input data are correct.
 
Output

            The result of the program is on standard output. For each input data set the program prints on a single line, starting from the beginning of the line, one integer: the minimum number of paratroopers required to visit all the intersections in the town.
 
Sample Input
2
4
3
3 4
1 3
2 3
3
3
1 3
1 2
2 3
 
Sample Output
2
1
 
 
Source
Asia 2002, Dhaka (Bengal)
 
Recommend
Ignatius.L
 


题目大意:

         一个城市里有n个十字路口,m条街道,要在十字路口上降落伞兵,伞兵可以搜索到降落的那个路口或者沿着此路口所连接的街道搜索到其他路口,使伞兵能找到全部路口,求此时的最小值,即降落伞兵的最小数量


题目分析:

              求有向无环图的最小路径覆盖。有向无环图的最小路径覆盖 = 节点数 - 最大匹配数。

1、以下时需要用到的一些知识点:

顶点覆盖:

在顶点集合中,选取一部分顶点,这些顶点能够把所有的边都覆盖了。这些点就是顶点覆盖集

最小顶点覆盖:

在所有的顶点覆盖集中,顶点数最小的那个叫最小顶点集合。

独立集:

在所有的顶点中选取一些顶点,这些顶点两两之间没有连线,这些点就叫独立集

最大独立集:

在左右的独立集中,顶点数最多的那个集合

路径覆盖:

在图中找一些路径,这些路径覆盖图中所有的顶点,每个顶点都只与一条路径相关联。

最小路径覆盖:

在所有的路径覆盖中,路径个数最小的就是最小路径覆盖了。


2、其中至于第一个案例中为什么最小路径覆盖的答案是2,查看一下:http://blog.csdn.net/hjd_love_zzt/article/details/44243725

就知道了。





代码如下:

/*
 * c.cpp
 *
 *  Created on: 2015年3月13日
 *      Author: Administrator
 */

#include <iostream>
#include <cstdio>
#include <cstring>


using namespace std;

const int maxn = 121;

int map[maxn][maxn];
int useif[maxn];
int link[maxn];

int n;

bool can(int t){
	int i;
	for(i = 1 ; i <= n ; ++i){
		if(useif[i] == false && map[t][i] == true){
			useif[i] = true;
			if(link[i] == -1 || can(link[i])){
				link[i] = t;

				return true;
			}
		}
	}

	return false;
}


int max_match(){
	int num = 0;

	int i;
	for(i = 1 ; i <= n ; ++i){//需要注意的是,本题中结点序号是从1开始的,而不是从0开始的.所以这里要写成1开始,否则果断的WA
	memset(useif,false,sizeof(useif));
		if(can(i) == true){
			num++;
		}
	}

	return num;
}


int main(){
	int t;
	scanf("%d",&t);
	while(t--){
		memset(map,false,sizeof(map));
		memset(link,-1,sizeof(link));


		int m;
		scanf("%d",&n);
		scanf("%d",&m);

		int i;
		for(i = 0 ; i < m ; ++i){
			int a,b;
			scanf("%d %d",&a,&b);
			map[a][b] = true;
		}


		//有向无环图的最小路径覆盖 = 节点数 - 最大匹配数
		printf("%d\n",n- max_match());
	}

	return 0;
}








  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

帅气的东哥

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值