UVa11054 poj2940 sdut2370 Wine trading in Gergovia(贪心)

Wine trading in Gergovia

Time Limit: 1000ms   Memory limit: 65536K  有疑问?点这里^_^

题目描述

As you may know from the comic "Asterix and the Chieftain\'s Shield", Gergovia consists of one street, and every inhabitant of the city is a wine salesman. You wonder how this economy works? Simple enough: everyone buys wine from other inhabitants of the city. Every day each inhabitant decides how much wine he wants to buy or sell. Interestingly, demand and supply is always the same, so that each inhabitant gets what he wants.

There is one problem, however: Transporting wine from one house to another results in work. Since all wines are equally good, the inhabitants of Gergovia don\'t care which persons they are doing trade with, they are only interested in selling or buying a specific amount of wine. They are clever enough to figure out a way of trading so that the overall amount of work needed for transports is minimized.

In this problem you are asked to reconstruct the trading during one day in Gergovia. For simplicity we will assume that the houses are built along a straight line with equal distance between adjacent houses. Transporting one bottle of wine from one house to an adjacent house results in one unit of work.

输入

The input consists of several test cases.
Each test case starts with the number of inhabitants n (2 ≤ n ≤ 100000). The following line contains n integers ai (-1000 ≤ ai ≤ 1000). If ai ≥ 0, it means that the inhabitant living in the ith house wants to buy ai bottles of wine, otherwise if ai < 0, he wants to sell -ai bottles of wine. You may assume that the numbers ai sum up to 0.
The last test case is followed by a line containing 0.

输出

For each test case print the minimum amount of work units needed so that every inhabitant has his demand fulfilled. You may assume that this number fits into a signed 64-bit integer (in C/C++ you can use the data type "long long", in JAVA the data type "long").

示例输入

5
5 -4 1 -3 1
6
-1000 -1000 -1000 1000 1000 1000
0

示例输出

9
9000

 

分析:

一个供求平衡的城市,各个商家一字摆开,且单位路程交易产生单位工作量,贪心求最小工作量。

从第一家开始向后每个商家都跟邻居交易,另辟数组储存每次交易工作量,加和即可

 

#include<stdio.h>
#include<math.h>
int s[100010],t[100010];
int main()
{
 int n,i;
 long long sum;
 while(scanf("%d",&n),n!=0)
 {
  for(i=1;i<=n;i++)
  {
   scanf("%d",&s[i]);
  }
  sum=0;t[0]=0;
  for(i=1;i<=n;i++)
  {
   t[i]=t[i-1]+s[i];
   sum+=fabs(t[i]);
  }
  printf("%lld\n",sum);
 }
 return 0;
}


 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值