POJ 1159 Palindrome 动态规划+滚动数组

Palindrome
Time Limit: 3000MS Memory Limit: 65536K
Total Submissions: 50689 Accepted: 17461

Description

A palindrome is a symmetrical string, that is, a string read identically from left to right as well as from right to left. You are to write a program which, given a string, determines the minimal number of characters to be inserted into the string in order to obtain a palindrome. 

As an example, by inserting 2 characters, the string "Ab3bd" can be transformed into a palindrome ("dAb3bAd" or "Adb3bdA"). However, inserting fewer than 2 characters does not produce a palindrome. 

Input

Your program is to read from standard input. The first line contains one integer: the length of the input string N, 3 <= N <= 5000. The second line contains one string with length N. The string is formed from uppercase letters from 'A' to 'Z', lowercase letters from 'a' to 'z' and digits from '0' to '9'. Uppercase and lowercase letters are to be considered distinct.

Output

Your program is to write to standard output. The first line contains one integer, which is the desired minimal number.

Sample Input

5
Ab3bd

Sample Output

2

Source



题目大意:

给你一段字符串,让你求出在中间最少加入几个字符可以让他变成一段回文子串。

解题思路:

假设S是一段字符串,S'是S的逆串,则只需求出S与S'的最长公共子序列即可的长度即可,最后用字符串的长度减去最长公共子序列的长度即是这道题目所求的加入的字母的长度。转化为LCS即可。

关键是如果直接开DP[5005][5005]会MLE,所以就显现出了动态数组的重要性。

代码如下:

#include <iostream>
#define Max 5005
using namespace std;

char s1[Max],s2[Max];
int dp[2][Max];   //定义二维动态滚动数组(本题以01行滚动)
int main()
{
	int n,i,j;
	while(cin>>n)
	{
		dp[0][0]=dp[1][0]=0; //动态数组初始化 行开头为全0
		for(i=1,j=n;i<=n;i++,j--)
		{
			dp[0][i]=dp[1][i]=0;  //动态数组初始化 列开头为全0
			char tmp;
			cin>>tmp;
			s1[i]=s2[j]=tmp;
		}

		int max_len=0;
		for(i=1;i<=n;i++)
			for(j=1;j<=n;j++)
			{
				if(s1[i]==s2[j])
					dp[i%2][j]=dp[(i-1)%2][j-1]+1;   //如果字符相等,则继承前一行前一列的dp值+1
				else
					dp[i%2][j]=max(dp[(i-1)%2][j],dp[i%2][j-1]); //否则,取上方或左方的最大dp值

				if(max_len<dp[i%2][j])
					max_len=dp[i%2][j];
			}
        cout<<n-max_len<<endl;
	}
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值