DP之Wooden Sticks ---解题报告

DP之Wooden Sticks

Wooden Sticks

Time Limit : 2000/1000ms(Java/Other)   Memory Limit : 65536/32768K (Java/Other)

Total Submission(s) : 7   AcceptedSubmission(s) : 6

Font: Times New Roman | Verdana | Georgia

Font Size: ← →

Problem Description

There is a pile of n wooden sticks. The length and weightof each stick are known in advance. The sticks are to be processed by awoodworking machine in one by one fashion. It needs some time, called setuptime, for the machine to prepare processing a stick. The setup times areassociated with cleaning operations and changing tools and shapes in themachine. The setup times of the woodworking machine are given as follows:

(a) The setup time for the first wooden stick is 1 minute.
(b) Right after processing a stick of length l and weight w , the machine willneed no setup time for a stick of length l' and weight w' if l<=l' andw<=w'. Otherwise, it will need 1 minute for setup.

You are to find the minimum setup time to process a given pile of n woodensticks. For example, if you have five sticks whose pairs of length and weightare (4,9), (5,2), (2,1), (3,5), and (1,4), then the minimum setup time shouldbe 2 minutes since there is a sequence of pairs (1,4), (3,5), (4,9), (2,1),(5,2).

Input

The input consists of T test cases. The number of testcases (T) is given in the first line of the input file. Each test case consistsof two lines: The first line has an integer n , 1<=n<=5000, thatrepresents the number of wooden sticks in the test case, and the second linecontains n 2 positive integers l1, w1, l2, w2, ..., ln, wn, each of magnitudeat most 10000 , where li and wi are the length and weight of the i th woodenstick, respectively. The 2n integers are delimited by one or more spaces.

Output

The output should contain the minimum setup time inminutes, one per line.

Sample Input

3

5

4 9 5 2 2 1 3 5 1 4

3

2 2 1 1 2 2

3

1 3 2 2 3 1

Sample Output

2

1

3

Source

Asia 2001, Taejon (South Korea)

 

 

题目的大概意思是说,有一堆木材需要加工,第一根木材加工需要1分钟,如果其他的木材的长度和宽度都大于或等于已经加工过的木材,则这根木材的加工不费时间,否则时间也为1分钟。求至少需要用多长时间。

用动态规划的思路是这样的,该题同样类似于拦截导弹的问题,而其根本的就是子序列问题,也就是说,最长递增子序列的个数 = = 最长不增子序列的长度
注意:最长不减子序列的个数 = = 最长递减子序列的长度
      最长不增子序列的个数 = = 最长递增子序列的长度
      最长递增子序列的个数 = = 最长不增子序列的长度
      最长递减子序列的个数 = = 最长不减子序列的长度

代码如下:

#include <iostream>
#include <algorithm>
#include <string.h>
using namespace std;
const int N=5001;
int d[N],dp[N],p[N];//d数据数组,dp有序序列的长度数组,p记录位置的数组
int e;//最长有序子序列的最后元素的下标
int LIS(int n)//n:输入数据的个数
{
    int max1=0,max2=0;
    for(int i=0;i<n;i++)
    {
        dp[i]=0;p[i]=-1;//为f和p赋初值
        for(int j=0;j<i;j++)
        {
            if(d[j]>d[i]&&dp[j]>max1)// d[j]<d[i]:递增子序列;d[j]<=d[i]不减子序列
            { //d[j]>d[i]:递减子序列;d[j]>=d[i]不增子序列
                max1=dp[j];p[i]=j;
            }
        }
        dp[i]=max1+1;max1=0;
        if(dp[i]>max2)
        {
            max2=dp[i];e=i;
        }
    }
    return max2;
}
void printLIS(int e)//输出路径
{
    if(p[e]!=-1)printLIS(p[e]);
    cout<<d[e]<<endl;
}
struct Stick
{
    int l,w;
}s[5000];
int cmp(Stick s1,Stick s2)
{
    if(s1.l<s2.l)return 1;
    else if(s1.l>s2.l)return 0;
    else return s1.w<s1.w;
}
int main()
{
    int t;
    cin>>t;
    while(t--)
    {
        int n;
        cin>>n;
        for(int i=0;i<n;i++)
        {
            cin>>s[i].l>>s[i].w;

        }
        sort(s,s+n,cmp);
         for(int i=0;i<n;i++)
        {
            d[i]=s[i].w;

        }
        cout<<LIS(n)<<endl;
    }
    return 0;
}

 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值