Fire net 之DFS解题报告

Fire Net

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 4531    Accepted Submission(s): 2577


Problem Description
Suppose that we have a square city with straight streets. A map of a city is a square board with n rows and n columns, each representing a street or a piece of wall.

A blockhouse is a small castle that has four openings through which to shoot. The four openings are facing North, East, South, and West, respectively. There will be one machine gun shooting through each opening.

Here we assume that a bullet is so powerful that it can run across any distance and destroy a blockhouse on its way. On the other hand, a wall is so strongly built that can stop the bullets.

The goal is to place as many blockhouses in a city as possible so that no two can destroy each other. A configuration of blockhouses is legal provided that no two blockhouses are on the same horizontal row or vertical column in a map unless there is at least one wall separating them. In this problem we will consider small square cities (at most 4x4) that contain walls through which bullets cannot run through.

The following image shows five pictures of the same board. The first picture is the empty board, the second and third pictures show legal configurations, and the fourth and fifth pictures show illegal configurations. For this board, the maximum number of blockhouses in a legal configuration is 5; the second picture shows one way to do it, but there are several other ways.



Your task is to write a program that, given a description of a map, calculates the maximum number of blockhouses that can be placed in the city in a legal configuration.
 

Input
The input file contains one or more map descriptions, followed by a line containing the number 0 that signals the end of the file. Each map description begins with a line containing a positive integer n that is the size of the city; n will be at most 4. The next n lines each describe one row of the map, with a '.' indicating an open space and an uppercase 'X' indicating a wall. There are no spaces in the input file.
 

Output
For each test case, output one line containing the maximum number of blockhouses that can be placed in the city in a legal configuration.
 

Sample Input
  
  
4 .X.. .... XX.. .... 2 XX .X 3 .X. X.X .X. 3 ... .XX .XX 4 .... .... .... .... 0
 

Sample Output
  
  
5 1 5 2 4
 

Source
Zhejiang University Local Contest 2001

题目大意:

该题简单易懂,但实现起来并不那么容易,题目给出的依旧是二维数组模型的地图分布,或者说是“九宫格”形式,每一格可以设置为‘.’,也可以设置为‘X’,‘.’表示可行空道,‘X’表示墙,问在空带上最多可以设置多少个碉堡。其中碉堡的设置需满足两个碉堡不能同行不能同列,除非两两之间有墙相阻隔,求最大的安置碉堡数。


算法解析:
本题可以采用深度优先算法,也可以采用贪心算法,贪心算法点击这里( http://blog.csdn.net/caizi1991/article/details/8995928)。由于题目中给定了墙的具体位置,那么,如果采用DFS的话,必须要对以每一个可安置节点为首安置都进行遍历,算法复杂度比较高。对数组的处理有采用了“循环模式”。当前点遍历完后,再回朔为未放,这样就可以把每种情况都考虑进去了,如果不可以放置, 就直接判断下一个点。到最后把最大的值记录下来,就完成搜索了。
代码如下:
//该思路的主要思想就是将第一个安装在可以安装的点,依次深度遍历,找到最大的安置数
#include <iostream>
using namespace std;

char map[5][5];
int Max,n;

int IsSet(int row,int col)
{
    int i;
    for(i=col-1;i>=0;i--)   //判断每一列是否可以放置
    {
        if(map[row][i]=='0')
            return 0;
        if(map[row][i]=='X')
            break;
    }
    for(i=row-1;i>=0;i--)   //判断每一行是否可以放置
    {
        if(map[i][col]=='0')
            return 0;
        if(map[i][col]=='X')
            break;
    }
    return 1;
}

void DFS(int k,int num)
{
    int x,y;
    if(k==n*n)      //类似于存储结构为一维数组的模型
    {
        if(num>Max)
        {
            Max=num;      //当以当前第一个安置点为开始遍历的路径到达终点后,返回上一层安置点位置
            return;
        }
    }
    else
    {
        x=k/n;
        y=k%n;
        if((map[x][y]=='.')&&(IsSet(x,y)==1))   //表示该处可以放置
        {
            map[x][y]='0';      //将该处放置碉堡
            DFS(k+1,num+1);     //继续下一个位置
            map[x][y]='.';      //回溯,将该点还原
        }
        DFS(k+1,num);      //继续下一个位置的遍历
    }
}

int main()
{
    int i,j;
    while(cin>>n&&n)
    {
        for(i=0;i<n;i++)
            for(j=0;j<n;j++)
                cin>>map[i][j];
        Max=0;
        DFS(0,0);
        cout<<Max<<endl;
    }
    return 0;
}


  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值