一、堂前习题
1.在下面程序中填充定义字符数组的语句,使程序完整。
#include "stdio.h"
#include "string.h"
int main()
{
_______________________/*define a array named s to store string*/
strcpy(s, "abcdefghijklmn");
printf("%s", s);
return 0;
}
代码如下(示例):
#include "stdio.h"
#include "string.h"
int main()
{
char s[20];/*define a array named s to store string*/
strcpy(s, "abcdefghijklmn");
printf("%s", s);
return 0;
}
2.从键盘输入3个字符串(每个字符串以回车符做为结束标志),将3个字符串以输入先后顺序合并到字符串s中,请填空使用程序完整。
#include "stdio.h"
#include "string.h"
main()
{
char s[100]="";
char a[30];
_______________________
printf("%s", s);
}
输入样例
123
abc
456
输出样例
123abc456
代码如下(示例):
#include "stdio.h"
#include "string.h"
main()
{
char s[100]="";
char a[30];
char a1[30];
char a2[30];
gets(a);gets(a1);gets(a2);
strcat(s,a);strcat(s,a1);strcat(s,a2);//从斜杠0的位置开始连接(会替代斜杠0)
printf("%s", s);
}
3.下面程序实现从键盘读入字符串,然后输出到屏幕,请填充必要的语句。
#include "stdio.h"
main()
{ char s[50];
printf("What's your name?\n");
_______________________ /*iput your name from the keyboard*/
printf("Your name is ");
printf("_______________________", s); /*output your name*/
}
输入样例
Wang
输出样例
What’s your name?
Your name is Wang
代码如下(示例):
#include "stdio.h"
main()
{ char s[50];
printf("What's your name?\n");
gets(s);
printf("Your name is ");
printf("%s", s); /*output your name*/
}