实验8_字符数组及串_堂前习题

一、堂前习题

1.在下面程序中填充定义字符数组的语句,使程序完整。

#include "stdio.h"
#include "string.h"
int main()
{
    _______________________/*define a array named s to store string*/
    strcpy(s, "abcdefghijklmn");
    printf("%s", s);
    return 0;
}

代码如下(示例):

#include "stdio.h"
#include "string.h"
int main()
{
    char s[20];/*define a array named s to store string*/
    strcpy(s, "abcdefghijklmn");
    printf("%s", s);
    return 0;
}

2.从键盘输入3个字符串(每个字符串以回车符做为结束标志),将3个字符串以输入先后顺序合并到字符串s中,请填空使用程序完整。

#include "stdio.h"
#include "string.h"
main()
{
    char s[100]="";
    char a[30];
    _______________________
    printf("%s", s);
}

输入样例
123
abc
456
输出样例
123abc456

代码如下(示例):

#include "stdio.h"
#include "string.h"
main()
{
    char s[100]="";
    char a[30];
    char a1[30];
    char a2[30];
    gets(a);gets(a1);gets(a2);
    strcat(s,a);strcat(s,a1);strcat(s,a2);//从斜杠0的位置开始连接(会替代斜杠0)
    printf("%s", s);
}

3.下面程序实现从键盘读入字符串,然后输出到屏幕,请填充必要的语句。

#include "stdio.h"
main()
{   char  s[50];
    printf("What's your name?\n");
    _______________________ /*iput your name from the keyboard*/
    printf("Your name is ");
    printf("_______________________", s);  /*output your name*/
}

输入样例
Wang
输出样例
What’s your name?
Your name is Wang

代码如下(示例):

#include "stdio.h"
main()
{   char  s[50];
    printf("What's your name?\n");
    gets(s);
    printf("Your name is ");
    printf("%s", s);  /*output your name*/
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值