Description:编写一个函数,给出年、月、日,计算该日是本年的第几天。
Input
输入仅一行,输入年、月、日,用空格隔开。
Output
输出仅一行,该日是本年的第几天。
Sample Input
2000 5 8
Sample Output
129
#include <stdio.h>
int main()
{
int x=0,y=0,z=0,days=0,i;
int months[12]={31,28,31,30,31,30,31,31,30,31,30,31};
scanf("%d %d %d",&x,&y,&z);
if((x%4==0&&x%100!=0)||(x%400==0))
months[1]=29;
else
months[1]=28;
for(i=0;i<y-1;i++)
{
days+=months[i];
}
days+=z;
printf("%d\n",days);
return 0;
}
编译结果如下: