hdu1055 Color a Tree

Color a Tree

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 2551    Accepted Submission(s): 937


Problem Description
Bob is very interested in the data structure of a tree. A tree is a directed graph in which a special node is singled out, called the "root" of the tree, and there is a unique path from the root to each of the other nodes. 

Bob intends to color all the nodes of a tree with a pen. A tree has N nodes, these nodes are numbered 1, 2, ..., N. Suppose coloring a node takes 1 unit of time, and after finishing coloring one node, he is allowed to color another. Additionally, he is allowed to color a node only when its father node has been colored. Obviously, Bob is only allowed to color the root in the first try. 

Each node has a “coloring cost factor”, Ci. The coloring cost of each node depends both on Ci and the time at which Bob finishes the coloring of this node. At the beginning, the time is set to 0. If the finishing time of coloring node i is Fi, then the coloring cost of node i is Ci * Fi. 

For example, a tree with five nodes is shown in Figure-1. The coloring cost factors of each node are 1, 2, 1, 2 and 4. Bob can color the tree in the order 1, 3, 5, 2, 4, with the minimum total coloring cost of 33.



Given a tree and the coloring cost factor of each node, please help Bob to find the minimum possible total coloring cost for coloring all the nodes.
 

Input
The input consists of several test cases. The first line of each case contains two integers N and R (1 <= N <= 1000, 1 <= R <= N), where N is the number of nodes in the tree and R is the node number of the root node. The second line contains N integers, the i-th of which is Ci (1 <= Ci <= 500), the coloring cost factor of node i. Each of the next N-1 lines contains two space-separated node numbers V1 and V2, which are the endpoints of an edge in the tree, denoting that V1 is the father node of V2. No edge will be listed twice, and all edges will be listed. 

A test case of N = 0 and R = 0 indicates the end of input, and should not be processed. 
 

Output
For each test case, output a line containing the minimum total coloring cost required for Bob to color all the nodes.
 

Sample Input
 
 
5 11 2 1 2 41 21 32 43 50 0
 

Sample Output
 
 
33
 

Source

/*
题意:
一棵树,结点树为n,根结点为r。每个结点都有一个权值ci,开始时间为0,每染色一个结点需要耗时1,每个结点的染色代价为ci*ti(ti为当前的时间),每个结点只有在父结点已经被染色的条件下才能被染色。求染完整棵树需要花费的最小代价。
题解:
结论:对于一个非根结点,它具有非根结点的最大权值,那么访问完它的父结点后就要立即访问它才能使得代价最小。
处理过程:
1)建立结构体node,结构体数组e[i]表示i结点的状态,e[i].c=ci为总权值,e[i].w=ci为当前权值,e[i].t=1为经过这个结点需要的耗时(
也可以理解为这个结点包含几个合并的结点),e[i].pre为父结点.
2)找到一个最大权值非根结点,将其m与其父亲p合并形成一个新的结点,新结点还是原来p的位置,这个新结点的子结点为m和p的子结点;
ans+=e[m].c*e[p].t,表示经过父节点p后,需要经历e[p].t时间才到达m,所以将m同p合并后,总代价要加上这段路径的代价;
新结点的情况e[p].c+=e[m].c,e[p].t+=e[m].t,e[p].w=1.0*e[p].c/e[p].t(新结点权值变成算术平均值,因为到这个结点的代价被平分分给t个结点)。
3)重复2)直到结点只有一个为止。
4)ans+=∑ci,因为本身染色需要耗时1,也就要支付代价ci*1.
*/

#include<stdio.h>
const int maxn=1010;
struct node{
	int pre,c,t;
	double w;//权值 
}e[maxn];

int find_where(int n,int r)
{
	int i,j,k,p;
	double maxv=-1;
	for(i=1;i<=n;i++)
	{
		if(i==r) continue;//跳过根节点。 
		if(e[i].w>maxv)//找到权值最大的节点 
		{
			maxv=e[i].w;
			p=i; 
		} 
	}
	return p;
}

int main()
{
	int n,r;
	while(scanf("%d%d",&n,&r)!=EOF)//n代表节点个数,r代表根节点序号 
	{
		if(n==0&&r==0)
		break;
		int i,j,k,a,b,m,p,ans=0;
		for(i=1;i<=n;i++)
		{
			scanf("%d",&e[i].c);
			e[i].w=e[i].c;
			e[i].t=1;
			ans+=e[i].c;
		}
		for(i=1;i<n;i++)
		{
			scanf("%d%d",&a,&b);
			e[b].pre=a;
		}
		
		for(i=1;i<n;i++)//核心代码 
		{
			m=find_where(n,r);
			e[m].w=0;
			p=e[m].pre;
			ans+=e[m].c*e[p].t;
			for(j=1;j<=n;j++)
			{
				if(e[j].pre==m)
				e[j].pre=p;
			}
			e[p].c+=e[m].c;
			e[p].t+=e[m].t;
			e[p].w=1.0*e[p].c/e[p].t;
		}
		printf("%d\n",ans);
	}
	return 0;
}

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值