nyoj234 吃土豆

吃土豆

时间限制: 1000 ms  |  内存限制: 65535 KB
难度: 4
描述
Bean-eating is an interesting game, everyone owns an M*N matrix, which is filled with different qualities beans. Meantime, there is only one bean in any 1*1 grid. Now you want to eat the beans and collect the qualities, but everyone must obey by the following rules: if you eat the bean at the coordinate(x, y), you can’t eat the beans anyway at the coordinates listed (if exiting): (x, y-1), (x, y+1), and the both rows whose abscissas are x-1 and x+1.


Now, how much qualities can you eat and then get ?
输入
There are a few cases. In each case, there are two integer M (row number) and N (column number). The next M lines each contain N integers, representing the qualities of the beans. We can make sure that the quality of bean isn't beyond 1000, and 1<=M,N<=500.
输出
For each case, you just output the MAX qualities you can eat and then get.
样例输入
4 6
11 0 7 5 13 9
78 4 81 6 22 4
1 40 9 34 16 10
11 22 0 33 39 6
样例输出
242
来源
/*
吃了某个土豆,那它上面那行和下面那行就不能吃了,左右两个邻居也不能吃了 
对于行和列来说是一样的 不能取i-1,i+1行(列)
因此
对于列来说map[i][j]+=max(map[i][j-2],max[i][j-3]);
对于行来讲dp[i]=max(dp[i-2],dp[i-3])+max(map[i][m+1],map[i][m+2]);每行有m列 
*/
#include<algorithm>
#include<cstring>
#include<cstdio>
using namespace std;
int dp[510];
int map[510][510];
 
int main()
{
	int n,m,i,j;
	while(scanf("%d%d",&n,&m)!=EOF)
	{
		memset(dp,0,sizeof(dp));
		memset(map,0,sizeof(map));
		//因为动态转移方程需要用到i-3,所以从3开始输入,防止访问非法内存
		for(i=3;i<n+3;i++)//行 上下 
		{
			for(j=3;j<m+3;j++)//列 左右 
			{
				scanf("%d",&map[i][j]);
				map[i][j]+=max(map[i][j-2],map[i][j-3]);
			}
		}
		//先确定每行最大的,再去选列 
		for(i=3;i<n+3;i++)
		dp[i]=max(dp[i-2],dp[i-3])+max(map[i][m+1],map[i][m+2]);
		printf("%d\n",dp[n+2]);
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值