hdu1003 Max Sum 最大子段的和 模板题

Max Sum

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 279014    Accepted Submission(s): 66240


Problem Description
Given a sequence a[1],a[2],a[3]......a[n], your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14.
 

Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and 1000).
 

Output
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence. If there are more than one result, output the first one. Output a blank line between two cases.
 

Sample Input
 
 
25 6 -1 5 4 -77 0 6 -1 1 -6 7 -5
 

Sample Output
 
 
Case 1:14 1 4Case 2:7 1 6
 

Author
/*
要找出最大子段的和,首先想到的是枚举,枚举的方法是,分别将数串中的每一个数作为子段的第一位数,
然后子段长度依次递减。例如:
(2,-3,4,-1)这个数串枚举的所有情况为:
以2作为子段的第一位:2,(2,-3),(2,-3,4),(2,-3,3,-1)
以-3作为子段的第一位:-3,(-3,4),(-3,4,-1)
以4作为子段的第一位:4,(4,-1)
以-1作为子段的第一位:-1
从枚举的过程中发现:
当前子段和的值为负值时,就没必要再往下进行,而应将下一位数作为子段的第一位。
也就是说,当处理第i个数时,如果以第i-1个数为结尾的子段的和为正数,
则不必将第i个数作为新子段的首位进行枚举,因为新子段加上前面子段和所得的正数,
一定能得到更大的子段和。 
max_sum=max((sum+=a[i])<0?0:sum,max_sum);
*/
#include<stdio.h>
int main()
{
	int N,casenum=1;
	scanf("%d",&N);
	while(N--)
	{
		int n,i,max,sum,num,start,temp,end;
		scanf("%d",&n);
		sum=0;
		max=-999;
		temp=1;
		for(i=1;i<=n;i++)
		{
			scanf("%d",&num);
			sum+=num;
			if(sum>max)
			{
				max=sum;
				start=temp;
				end=i;
			}
		    if(sum<0)//当前子段和的值为负值时,就没必要再往下进行,而应将下一位数作为子段的第一位。
			{
				sum=0;
				temp=i+1;
			}
		}
	    printf("Case %d:\n%d %d %d\n",casenum++,max,start,end);
		if(N!=0)
		printf("\n");
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值