hdu1081 ToTheMax 最大子矩阵和 模板题

To The Max

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 14146    Accepted Submission(s): 6733


Problem Description
Given a two-dimensional array of positive and negative integers, a sub-rectangle is any contiguous sub-array of size 1 x 1 or greater located within the whole array. The sum of a rectangle is the sum of all the elements in that rectangle. In this problem the sub-rectangle with the largest sum is referred to as the maximal sub-rectangle.

As an example, the maximal sub-rectangle of the array:

0 -2 -7 0
9 2 -6 2
-4 1 -4 1
-1 8 0 -2

is in the lower left corner:

9 2
-4 1
-1 8

and has a sum of 15.
 

Input
The input consists of an N x N array of integers. The input begins with a single positive integer N on a line by itself, indicating the size of the square two-dimensional array. This is followed by N 2 integers separated by whitespace (spaces and newlines). These are the N 2 integers of the array, presented in row-major order. That is, all numbers in the first row, left to right, then all numbers in the second row, left to right, etc. N may be as large as 100. The numbers in the array will be in the range [-127,127].
 

Output
Output the sum of the maximal sub-rectangle.
 

Sample Input
 
 
40 -2 -7 0 
9 2 -6 2-4 1 -4 1 
-1 8 0 -2
 

Sample Output
 
 
15
 

Source
#include<stdio.h>
#include<string.h>
#include<limits.h>
int map[105][105];
int dp[105];
int n;

int getsum()
{ 
	int i,sum=0,max=0;
	for(i=0;i<n;i++)  //每一列 计算最大字段和  
   {  
      sum+=dp[i];  
      if(sum>max) 
	  max=sum;  
      if(sum<0) 
	  sum=0;   
   }
   return max;
}

int main()
{
	int i,j,k,ans,maxn;
	while(scanf("%d",&n)!=EOF)
	{
		for(i=0;i<n;i++)
	  	for(j=0;j<n;j++)
		scanf("%d",&map[i][j]);
    	ans=INT_MIN;//初始化一个最小值 包含于头文件 #include<limits.h>
		      
		for(i=0;i<n;i++)//从第i行开始 
		{
			memset(dp,0,sizeof(dp));	
			for(j=i;j<n;j++)//从i行到n-1行都尝试一下 
			{
				for(k=0;k<n;k++)//把j至k行的每一列都加起来,就是矩阵压缩 
				dp[k]+=map[j][k];
				ans=getsum();//计算压缩矩阵形成的一维数组的最长连续序列 
				
				if(maxn<ans)
				maxn=ans;
			}	
		}
    	printf("%d\n",maxn); 
 	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值