nyoj130 相同的雪花 排序 哈希表

相同的雪花

时间限制: 1000 ms  |  内存限制: 65535 KB
难度: 4
描述
You may have heard that no two snowflakes are alike. Your task is to write a program to determine whether this is really true. Your program will read information about a collection of snowflakes, and search for a pair that may be identical. Each snowflake has six arms. For each snowflake, your program will be provided with a measurement of the length of each of the six arms. Any pair of snowflakes which have the same lengths of corresponding arms should be flagged by your program as possibly identical.
输入
The first line of the input will contain a single interger T(0<T<10),the number of the test cases.
The first line of every test case will contain a single integer n, 0 < n ≤ 100000, the number of snowflakes to follow. This will be followed by n lines, each describing a snowflake. Each snowflake will be described by a line containing six integers (each integer is at least 0 and less than 10000000), the lengths of the arms of the snow ake. The lengths of the arms will be given in order around the snowflake (either clockwise or counterclockwise), but they may begin with any of the six arms. For example, the same snowflake could be described as 1 2 3 4 5 6 or 4 3 2 1 6 5.
输出
For each test case,if all of the snowflakes are distinct, your program should print the message:
No two snowflakes are alike.
If there is a pair of possibly identical snow akes, your program should print the message:
Twin snowflakes found.
样例输入
1
2
1 2 3 4 5 6
4 3 2 1 6 5
样例输出
Twin snowflakes found.
来源
/*
题意:让你输入n组数,每组6个数字围成的一个圈,问你有没有两组数字是完全一样的(顺时针和逆时针都可以)。
先将数字进行排序,如果想要两组数字一样,那首先他们的元素都是相同的,所以先进行排序。 
之后如果找到元素一样的两组数就再进行判断,是否次序也是一样的。
题意可能是为了考察哈希表,不过我感觉这题用哈希表有点牵强,有点为赋新词强说愁滴感觉。 
*/
#include<stdio.h>
#include<algorithm>
using namespace std;
struct SnowFlakes
{
	int a[6];
	int b[6];//用来保存未排序前的6个数值 
}s[100005];

int cmp(SnowFlakes s1,SnowFlakes s2)
{
	for(int i=0;i<6;i++)
	{
		if(s1.a[i]==s2.a[i])
		continue;
		return s1.a[i]<s2.a[i];
	}
	return -1;
}

bool judge(SnowFlakes s1,SnowFlakes s2)
{
	int i,j;
	for(i=0;i<6;i++)//顺时针 
	{
		for(j=0;j<6;j++)
		{
			if(s1.b[j]!=s2.b[(i+j)%6])
			break;
		}
		if(j==6)
		return true;
	}
	for(i=5;i>=0;i--)//逆时针 
	{
		for(j=0;j<6;j++)
		{
			if(s1.b[j]!=s2.b[(i-j+6)%6])
			break;
		}
		if(j==6)
		return true;
	}
	return false;
}

int main()
{
	int t,n,i,j;
	scanf("%d",&t);
	while(t--)
	{
		scanf("%d",&n);
		for(i=0;i<n;i++)
		{
			for(j=0;j<6;j++)
			{
				scanf("%d",&s[i].a[j]);
				s[i].b[j]=s[i].a[j];
			}
			sort(s[i].a,s[i].a+6);
		}
		sort(s,s+n,cmp);
		for(i=1;i<n;i++)
		{
			if(cmp(s[i],s[i-1])==-1&&judge(s[i],s[i-1]))
			break;
		}
		if(i==n)
		printf("No two snowflakes are alike.\n");
		else
		printf("Twin snowflakes found.\n");
	}
	return 0;
}
方法二 哈希表
#include<cstdio>
#include<vector>
using namespace std;
const int MAXN=100005;
const int MOD=5000;
int snow[MAXN][6];
int T,N,flag;
int t;
vector<int>Hash[MOD];//向量实现哈希表的存储

bool isSame(int a, int b) 
{
    for(int i=0;i<6;i++)
	{
        if((/*顺时针方向*/
			snow[a][0] == snow[b][i]       &&
            snow[a][1] == snow[b][(i+1)%6] &&
            snow[a][2] == snow[b][(i+2)%6] &&
            snow[a][3] == snow[b][(i+3)%6] &&
            snow[a][4] == snow[b][(i+4)%6] &&
            snow[a][5] == snow[b][(i+5)%6]
			)||(
			/*逆时针方向*/
			snow[a][0] == snow[b][(i+5)%6] &&
            snow[a][1] == snow[b][(i+4)%6] &&
            snow[a][2] == snow[b][(i+3)%6] &&
            snow[a][3] == snow[b][(i+2)%6] &&
            snow[a][4] == snow[b][(i+1)%6] &&
            snow[a][5] == snow[b][(i+0)%6]
			))
		  return true;
    }
	return false;
}


int main()
{
    scanf("%d",&T);
    while(T--)
	{
	    flag=0;//标记最终结果 
        scanf("%d",&N);
        for(int i=0;i<MOD;i++)//初始化容器 
        	Hash[i].clear();
        for(int i=0;i<N;i++)
		{
            int sum=0;
            for(int j=0;j<6;j++)//读入数据 
			{
                scanf("%d",&t);
                sum+=t;
                snow[i][j]=t;
            }
            sum%=MOD;//给每一组雪花一个特征值 
            Hash[sum].push_back(i);//在数组的最后添加一个数据 
        }
        for(int i=0;i<MOD;i++)
		{
            if(flag)
			break;
            if(Hash[i].size()<2) //如果连6个元素之和都没有重复的,则肯定不会相同。 
			continue;
            for(int j=0;j<Hash[i].size()-1;j++)
			{
                for(int k=j+1;k<Hash[i].size();k++)
				{
                    if(isSame(Hash[i][j],Hash[i][k]))
					{
                        flag=1;
						break;
                    }
                }
            }
        }
        if(flag)
		printf("Twin snowflakes found.\n");
        else 
		printf("No two snowflakes are alike.\n");
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值