uva10012


  How Big Is It? 

Ian's going to California, and he has to pack his things, including his collection of circles. Given a set of circles, your program must find the smallest rectangular box in which they fit. All circles must touch the bottom of the box. The figure below shows an acceptable packing for a set of circles (although this may not be the optimal packing for these particular circles). Note that in an ideal packing, each circle should touch at least one other circle (but you probably figured that out).

Input 

The first line of input contains a single positive decimal integer  n n <=50. This indicates the number of lines which follow. The subsequent  n  lines each contain a series of numbers separated by spaces. The first number on each of these lines is a positive integer  m m <=8, which indicates how many other numbers appear on that line. The next  m  numbers on the line are the radii of the circles which must be packed in a single box. These numbers need not be integers.

Output 

For each data line of input, excluding the first line of input containing  n , your program must output the size of the smallest rectangle which can pack the circles. Each case should be output on a separate line by itself, with three places after the decimal point. Do not output leading zeroes unless the number is less than 1, e.g.  0.543 .

Sample Input 

3
3 2.0 1.0 2.0
4 2.0 2.0 2.0 2.0
3 2.0 1.0 4.0

Sample Output 

9.657
16.000
12.657


Miguel Revilla 
2000-08-22


单单排列是不行的,因为有可能两个大圆中间夹着一个小圆,或者最边界的小圆不与边界相切,而是处于相对中间的大圆,所以每次排列一个圆要与所有圆相切一次求最远的圆心距离,然后求各个圆所能达到的最远边界,两边的最远边界相减就是答案了


#include<stdio.h>
#include<string.h>
#include<iostream>
#include<math.h>
using namespace std;
#define maxn 0xffffffff
int n,vis[10];
double r[10],R[10],dist[10],minn;
void dfs(int x)
{
	int i,j;
	double ff,right,left;
	if(x==n)
	{
		dist[0]=0;
		for(i=1;i<n;i++)
		{
			dist[i]=0;
			for(j=0;j<i;j++)
			{
				ff=sqrt(4*R[i]*R[j]);
				if(dist[i]<dist[j]+ff)
					dist[i]=ff+dist[j];
			}
		}
		right=-maxn;left=maxn;
		for(i=0;i<n;i++)
		{
			if(dist[i]+R[i]>right)right=dist[i]+R[i];
			if(dist[i]-R[i]<left)  left=dist[i]-R[i];
		}
		if(right-left<minn)
			minn=right-left;
		return ;
	}
	for(i=0;i<n;i++)
	{
		if(!vis[i])
		{
			vis[i]=1;
			R[x]=r[i];
			dfs(x+1);
			vis[i]=0;
		}
	}
}
main()
{
	int i,t;
	//freopen("D:\\u.txt","r",stdin);
	scanf("%d",&t);
	while(t--)
	{
		memset(vis,0,sizeof(vis));
		scanf("%d",&n);
		for(i=0;i<n;i++)
			scanf("%lf",&r[i]);
		minn=maxn;
		dfs(0);
		printf("%.3lf\n",minn);
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值