PAT A1040. Longest Symmetric String (25)

原题:


1040. Longest Symmetric String (25)

Given a string, you are supposed to output the length of the longest symmetric sub-string. For example, given “Is PAT&TAP symmetric?”, the longest symmetric sub-string is “s PAT&TAP s”, hence you must output 11.

Input Specification:

Each input file contains one test case which gives a non-empty string of length no more than 1000.

Output Specification:

For each test case, simply print the maximum length in a line.

Sample Input:

Is PAT&TAP symmetric?

Sample Output:

11

题解:


题目大意

Given a string, you are supposed to output the length of the longest symmetric sub-string
即输出序列内最大的对称序列

输入

单行:字符串
    --String String.size() <= 1000

输出

输出最大的序列的字符数

测评结果

这里写图片描述

代码实现


#include <iostream>
#include <string>

int main ()
{
    std::string in;
    std::getline(std::cin, in);
    auto len = in.size();
    int32_t ret = -1;
    for (int32_t i = 0; i < len; )
    {
        int32_t start = i-1, end=i+1, _tmp = 1;
        while (end < len &&
                in[end] == in[i])
        {
            ++_tmp; ++end;
        }
        i = end;
        while (end < len && start >= 0 &&
                in[end++] == in[start--])
        {
            _tmp += 2;
        }
        if (_tmp > ret)
        {
            ret = _tmp;
        }
    }
    std::cout << ret << std::endl;
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值