PAT A1052. Linked List Sorting (25)

原题:


1052 Linked List Sorting (25)

A linked list consists of a series of structures, which are not necessarily adjacent in memory. We assume that each structure contains an integer key and a Next pointer to the next structure. Now given a linked list, you are supposed to sort the structures according to their key values in increasing order.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive N (< 105 10 5 ) and an address of the head node, where N is the total number of nodes in memory and the address of a node is a 5-digit positive integer. NULL is represented by -1.

Then N lines follow, each describes a node in the format:

Address Key Next

where Address is the address of the node in memory, Key is an integer in [ 105,105 − 10 5 , 10 5 ], and Next is the address of the next node. It is guaranteed that all the keys are distinct and there is no cycle in the linked list starting from the head node.

Output Specification:

For each test case, the output format is the same as that of the input, where N is the total number of nodes in the list and all the nodes must be sorted order.

Sample Input:

5 00001
11111 100 -1
00001 0 22222
33333 100000 11111
12345 -1 33333
22222 1000 12345

Sample Output:

5 12345
12345 -1 00001
00001 0 11111
11111 100 22222
22222 1000 33333
33333 100000 -1

题解:


题目大意

you are supposed to sort the structures according to their key values in increasing order.
即对链表按key值进行升序排序

输入

首行:总节点数N 首地址
    --N < 10^5
    --地址 5位非负数字,null为-1
N行:地址 key值 next
    --key -10^5 <= key <= 10^5 所有key值保证唯一
    --next 保证从head节点开始的链表没有循环

输出

首行:有效链表的总数 首地址
N行:按输入格式一次输出有效节点

测评结果

这里写图片描述

代码实现


#include <iostream>
#include <map>
#include <cassert>

const uint32_t max_id = 100001;
struct Node
{
    Node():addr(-1), key(0), next(-1)
    {
    }
    int32_t addr;
    int32_t key;
    int32_t next;
}Node[max_id];

int main()
{
    int32_t N, head;
    std::cin >> N >> head;
    for (int32_t i = 0; i != N; ++i)
    {
        int _addr, _key, _next;
        std::cin >> _addr >> _key >> _next;
        Node[_addr].addr = _addr;
        Node[_addr].key = _key;
        Node[_addr].next = _next;
    }   
    int32_t tmp_head = head;
    std::map<int32_t, int32_t>  sort_map;
    while (tmp_head != -1)
    {
        sort_map[Node[tmp_head].key] = tmp_head;
        tmp_head = Node[tmp_head].next;
    }
    auto find_iter = sort_map.begin();
    int32_t map_size = sort_map.size();
    if (find_iter == sort_map.end())
    {
        printf("0 -1\n");
        return 0;
    }
    printf("%d %05d\n", map_size, find_iter->second);

    int32_t index = 0;
    for (auto item : sort_map)
    {
        if (index != 0)
        {
            printf(" %05d\n", item.second);
        }
        printf("%05d %d", item.second, item.first);
        if (++index == map_size)
        {
            printf(" -1\n");
        }
    }
    return 0;
} 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值