uva1347 tour

John Doe, a skilled pilot, enjoys traveling. While on vacation, he rents a small plane and starts visiting beautiful places. To save money, John must determine the shortest closed tour that connects his destinations. Each destination is represented by a point in the plane pi = < xiyi > . John uses the following strategy: he starts from the leftmost point, then he goes strictly left to right to the rightmost point, and then he goes strictly right back to the starting point. It is known that the points have distinctx -coordinates.

Write a program that, given a set of n points in the plane, computes the shortest closed tour that connects the points according to John's strategy.

Input 

The program input is from a text file. Each data set in the file stands for a particular set of points. For each set of points the data set contains the number of points, and the point coordinates in ascending order of the x coordinate. White spaces can occur freely in input. The input data are correct.

Output 

For each set of data, your program should print the result to the standard output from the beginning of a line. The tour length, a floating-point number with two fractional digits, represents the result.


Note: An input/output sample is in the table below. Here there are two data sets. The first one contains 3 points specified by their x and y coordinates. The second point, for example, has the x coordinate 2, and the y coordinate 3. The result for each data set is the tour length, (6.47 for the first data set in the given example).

Sample Input 

3 
1 1
2 3
3 1
4 
1 1 
2 3
3 1
4 2

Sample Output 

6.47
7.89
 
题目大意:给出坐标平面上n个点,确定一条连接各点的最短闭合旅程的问题。
我们可以将单人旅途想象成从最左端的起点出发的两人走两条不同的路径最后在终点汇合。
动归:dp[i][j]表示一人走到i另一人走到j点时走的最短路程,因为dp[i][j]==dp[j][i],所以为了状态的唯一,规定i>j,即状态转移方程为:dp[i][j]=min(dp[i+1][j]+dis(i,i+1),dp[i+1][i]+dis(j,i+1)).

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>
#include <cstring>
using namespace std;
double g[1010][1010];
double dp[1010][1010];
struct node
{
    double x,y;
} no[1010];
double dis(node &x,node &y)
{
    return sqrt((x.x-y.x)*(x.x-y.x)+(x.y-y.y)*(x.y-y.y));
}
int main()
{
    int n;
    while(scanf("%d",&n)!=EOF)
    {
        memset(dp,0,sizeof(dp));
               for(int i=1; i<=n; i++)
               scanf("%lf%lf",&no[i].x,&no[i].y);
               for(int i = 2; i <= n; i++)
        {
            for(int j = 1; j < i; j++)
                {
                    g[i][j] = g[j][i] = dis(no[i], no[j]);
                }
            }
        for(int i=n-1;i>=2;i--)
                for(int j=1;j<i;j++)
                    if(i == n-1) dp[i][j] = g[j][n] + g[i][n];
                else
                dp[i][j]=min(dp[i+1][j]+g[i][i+1],dp[i+1][i]+g[j][i+1]);
        double ans=dp[2][1]+g[1][2];
        printf("%.2lf\n",ans);
    }  
} 

                
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值