统计难题
Time Limit: 4000/2000 MS (Java/Others) Memory Limit: 131070/65535 K (Java/Others)
Total Submission(s): 33555 Accepted Submission(s): 12730
Problem Description
Ignatius最近遇到一个难题,老师交给他很多单词(只有小写字母组成,不会有重复的单词出现),现在老师要他统计出以某个字符串为前缀的单词数量(单词本身也是自己的前缀).
Input
输入数据的第一部分是一张单词表,每行一个单词,单词的长度不超过10,它们代表的是老师交给Ignatius统计的单词,一个空行代表单词表的结束.第二部分是一连串的提问,每行一个提问,每个提问都是一个字符串.
注意:本题只有一组测试数据,处理到文件结束.
Output
对于每个提问,给出以该字符串为前缀的单词的数量.
Sample Input
banana
band
bee
absolute
acm
ba
b
band
abc
Sample Output
2
3
1
0
很明显的trie树,就不多说了。解题报告请看隔壁(慢慢羊羊)
代码:
#include <iostream>
#include <cstdio>
#include <algorithm>
#include <cstring>
using namespace std;
char s[12];
struct node
{
node* son[26];
int num;
node()
{
for(int i=0; i<26; i++)
son[i]=NULL;
num=0;
}
};
int trie(node * root, char* sc)
{
node* p=root;
while(sc[0]!='\0')
{
if(p->son[sc[0]-'a']==NULL)
{
node* p1=new node();
p1->num++;
p->son[sc[0]-'a']=p1;
p=p1;
}
else
{
p=p->son[sc[0]-'a'];
p->num++;
}
sc++;
}
return p->num;
}
int query(node * root, char* sc)
{
node* p=root;
while(sc[0]!='\0')
{
if(p->son[sc[0]-'a']==NULL)
{
return 0;
}
else
{
p=p->son[sc[0]-'a'];
}
sc++;
}
return p->num;
}
int main()
{
node *root=new node();
while(gets(s))
{
if(s[0]=='\0')
break;
trie(root,s);
}
while(scanf("%s",s)!=EOF)
{
cout<<query(root,s)<<endl;
}
return 0;
}