HDU 1061 Rightmost Digit

Problem Description

Given a positive integer N, you should output the most right digit of N^N.
 

Input

The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case contains a single positive integer N(1<=N<=1,000,000,000).

 
Output

For each test case, you should output the rightmost digit of N^N.

 
Sample Input

2
3
4
 

Sample Output

7
6


Answer

#include <iostream>
#include <cmath>
using namespace std;
int main()
{
 int n,i,x,y,a,b;
 cin>>n;
 for(i=0;i<n;i++)
 {
  cin>>x;
  a=x%10;
  if(a==0 || a==1 || a==5 || a==6)
   cout<<a<<endl;
  else
  {
    b=x%4+4;
    y=pow(a,b);
    cout<<y%10<<endl;
  }
 }
 return 0;
}

//  观察0-9 n次方的个位数 即可得出规律

0、1、5、6:均为本身

2:2 4 8 6 2 ...

3:3 9 7 1 3 ...

4:4 6 4 ...

7:7 9 3 1 7 ...

8:8 4 2 6 8 ...

9:9 1 9 ...

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值