给定一个带整数键值的链表 L,你需要把其中绝对值重复的键值结点删掉。即对每个键值 K,只有第一个绝对值等于 K 的结点被保留。同时,所有被删除的结点须被保存在另一个链表上。例如给定 L 为 21→-15→-15→-7→15,你需要输出去重后的链表 21→-15→-7,还有被删除的链表 -15→15。
输入格式:
输入在第一行给出 L 的第一个结点的地址和一个正整数 N(≤10
5
,为结点总数)。一个结点的地址是非负的 5 位整数,空地址 NULL 用 −1 来表示。
随后 N 行,每行按以下格式描述一个结点:
地址 键值 下一个结点
其中地址是该结点的地址,键值是绝对值不超过10
4
的整数,下一个结点是下个结点的地址。
输出格式:
首先输出去重后的链表,然后输出被删除的链表。每个结点占一行,按输入的格式输出。
输入样例:
00100 5
99999 -7 87654
23854 -15 00000
87654 15 -1
00000 -15 99999
00100 21 23854
输出样例:
00100 21 23854
23854 -15 99999
99999 -7 -1
00000 -15 87654
87654 15 -1
#include<bits/stdc++.h>
#include <math.h>
using namespace std;
struct Node{
int date;
int next;
}node[100000];
int vis[100000]={0};
int main()
{
int s,n,d,b,c,ad1[100001]={0},ad2[100001]={0};
cin>>s>>n;
for(int i=0;i<n;i++){
cin>>d>>b>>c;
node[d].date=b;
node[d].next=c;
}
int cnt=0,cnt2=0;
for(int i=s;i!=-1;i=node[i].next)
{
if(vis[ abs(node[i].date )] )
{
ad2[cnt2++]=i;
}
else
{
vis[ abs(node[i].date) ]=1;
ad1[cnt++]=i;
}
}
for(int i=0;i<cnt;i++){
cout<<setw(5)<<setfill('0')<<ad1[i]<<" "<<node[ad1[i]].date<<" ";
if(i!=cnt-1) cout<<setw(5)<<setfill('0')<<ad1[i+1]<<endl;
else cout<<"-1"<<endl;
}
for(int i=0;i<cnt2;i++){
cout<<setw(5)<<setfill('0')<<ad2[i]<<" "<<node[ad2[i]].date<<" ";
if(i!=cnt2-1) cout<<setw(5)<<setfill('0')<<ad2[i+1]<<endl;
else cout<<"-1"<<endl;
}
return 0;
}