pycharm安装第三方库一直报错

这个是我在重新安装pycharm的第三方库时遇到的报错,安装matplotlib,并指定了对应的版本号。报错内容大意就是网络问题。

根据报错内容,我又尝试在Terminal上输入pip命令来安装库,一直报错,显示无效字符,朋友说可能是pip没安装,或者没有更新到最新版本。但是我检查我的虚拟环境,里面pip的版本已经是最高了,就很奇怪。最后我还是去安装pip了,安装好后就能顺利推行了。下面是我手动安装pip的过程:(大家应该都会,我就记录一下,防止我自己忘记)

  1. 首先,请确保计算机已经安装了Python。可以在cmd中运行 python --version 命令来验证Python是否已正确安装以及版本号。

  2. 打开浏览器,访问 https://bootstrap.pypa.io/get-pip.py ,该链接指向pip的安装脚本。

  3. 在浏览器中,选择保存该脚本,并将其保存到计算机上的某个位置,比如桌面,也可以保存在cmd显示的目录下(后续就不用再转到Desktop中了)。

  4. 返回cmd窗口,使用 cd 命令导航到刚刚保存pip安装脚本的位置。例如,如果你将脚本保存在桌面上,则可以运行以下命令:cd C:\Users\Administrator\Desktop   (如果py文件保存在cmd显示的目录下,就不用输入这个命令)

  5. 运行以下命令执行pip安装脚本:python get-pip.py

  6. 完成安装后,可以验证pip是否已成功安装,运行以下命令:pip --version (可检查pip版本号)
  7. 安装完成就可以在cmd中pip进行安装了,(也可以运行以下命令:python    就可以运行python代码了)。
安装好pip,我仍然无法安装第三方库,甚至报了很长一段了错误,不管是手动安装还是,pip安装,或者使用镜像网站都会报同样的错:

 

红色字体的意思就是我安装的numpy版本不支持,这是一方面原因。我重新安装了numpy仍然不行,我开始看白色字体,could not fetch URL https://pypi.tuna.tsinghua.edu.cn/simple/pip/:Theressl certificate: HTTPSConnectionPool(hostssl.c:1131)'))) -skipping...差不多是这些,大意就是无法获取网页正在跳过什么的巴拉巴拉。。。我就切换镜像网站,但是依旧报错,我求助朋友后,他给我推荐了一篇博客There was a problem confirming the ssl certificate_滚雪球~的博客-CSDN博客

使用了pip install scipy -i http://mirrors.aliyun.com/pypi/simple --trusted-host mirrors.aliyun.com这行代码,很神奇,不管是指定版本还是直接安装,都很顺利!

这篇博客呢就是为了记录一下我再次装pycharm 时遇到的困难,一是为了后续可以方便查找,另外就是希望大家都能顺利的解决问题咯~

 

  • 3
    点赞
  • 3
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值