PAT 1107 Social Clusters

1107. Social Clusters (30)

When register on a social network, you are always asked to specify your hobbies in order to find some potential friends with the same hobbies. A "social cluster" is a set of people who have some of their hobbies in common. You are supposed to find all the clusters.

Input Specification:

Each input file contains one test case. For each test case, the first line contains a positive integer N (<=1000), the total number of people in a social network. Hence the people are numbered from 1 to N. Then N lines follow, each gives the hobby list of a person in the format:

Ki: hi[1] hi[2] ... hi[Ki]

where Ki (>0) is the number of hobbies, and hi[j] is the index of the j-th hobby, which is an integer in [1, 1000].

Output Specification:

For each case, print in one line the total number of clusters in the network. Then in the second line, print the numbers of people in the clusters in non-increasing order. The numbers must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input:
8
3: 2 7 10
1: 4
2: 5 3
1: 4
1: 3
1: 4
4: 6 8 1 5
1: 4
Sample Output:
3
4 3 
1
#include <cstdio>
#include <algorithm>
#include <cstring>
#include <iostream>
#include <set>
using namespace std;
int fa[1001];
void Init(){
	for(int i=1;i<=1000;i++){
		fa[i]=i;
	}
}
int Get(int x){
	return fa[x]=(fa[x]==x?x:Get(fa[x]));
}
void Merge(int x,int y){
	int a=Get(x);
	int b=Get(y);
	if(a!=b){
		fa[b]=a;
	}
}
int main(){
	set<int> s[1001];//每个爱好建立一个集合
	int n,m,num,cnt=0;//cnt为不相交集的个数
	int book[1001],count[1001];//book 标记出现的爱好 count 儿子计数
	memset(book,0,sizeof(book));
	memset(count,0,sizeof(count));
	Init();
	cin>>n;
	for(int i=1;i<=n;i++){
		cin>>m;
		getchar();
		for(int j=1;j<=m;j++){
			cin>>num;
			book[num]=1;
			s[num].insert(i);
		}
	}
	set<int> ::iterator it;
	for(int i=1;i<=1000;i++){
		if(book[i]){
			int x=*(s[i].begin());
			for(it=++s[i].begin();it!=s[i].end();it++){
				Merge(x,*it);
			}
		}
	}
	for(int i=1;i<=n;i++){
		int x=Get(i);
		cnt+=!count[x];
		count[x]++;
	}
	sort(count+1,count+n+1);
	cout<<cnt<<endl;
	for(int i=n;count[i];i--){
		cout<<count[i];
		printf("%c",count[i-1]==0?'\n':' ');
	}
	return 0;
}

//此题不用集合也能做,如vector
//此题也可以建图,用搜索做,搜索有几个连通分量
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值