03-树3 Tree Traversals Again (25分) (2020浙大Mooc数据结构配套题)

An inorder binary tree traversal can be implemented in a non-recursive way with a stack. For example, suppose that when a 6-node binary tree (with the keys numbered from 1 to 6) is traversed, the stack operations are: push(1); push(2); push(3); pop(); pop(); push(4); pop(); pop(); push(5); push(6); pop(); pop(). Then a unique binary tree (shown in Figure 1) can be generated from this sequence of operations. Your task is to give the postorder traversal sequence of this tree.


Alt

Figure 1

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (≤30) which is the total number of nodes in a tree (and hence the nodes are numbered from 1 to N). Then 2N lines follow, each describes a stack operation in the format: “Push X” where X is the index of the node being pushed onto the stack; or “Pop” meaning to pop one node from the stack.

Output Specification:

For each test case, print the postorder traversal sequence of the corresponding tree in one line. A solution is guaranteed to exist. All the numbers must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input:

6
Push 1
Push 2
Push 3
Pop
Pop
Push 4
Pop
Pop
Push 5
Push 6
Pop
Pop

Sample Output:

3 4 2 6 5 1

代码样例:

#include<stdio.h>
#include<stdlib.h>
#include<string.h>
#define MAXSIZE 30

typedef int ElementType;

/* Push是按照先序遍历,Pop是中续遍历,记录可得后续遍历 */ 
/* 定义三个数组,前中后,定义为全局变量方便操作 */
ElementType PreL[MAXSIZE], InL[MAXSIZE], PostL[MAXSIZE];

void GetPostL( int PreP, int InP, int PostP, int n);

int main()
{
	char s[10];
	int n,i,PreTop = 0,InTop = 0,StackTop = 0;
	ElementType num,Stack[MAXSIZE]; 
	
	scanf("%d",&n);//每个元素都要Push和Pop一次所以要循环2*n次 
	
	/* 循环求出前序和中序遍历 */ 
	for( i = 0; i < 2*n; i++){
		scanf("%s",&s);
		if( !strcmp( s, "Push") ){
			scanf("%d",&num);
			PreL[PreTop] = num;
			Stack[StackTop] = num;
			PreTop++;
			StackTop++;
		}else if( !strcmp( s, "Pop") ){
			StackTop--;
			InL[InTop] = Stack[StackTop];
			InTop++;
			
		}
	}
	
	GetPostL(0,0,0,n); 
	
	for( i = 0; i < n; i++){
		if( i == 0)
			printf("%d",PostL[i]);
		else
			printf(" %d",PostL[i]);
	}
}


/* PreP,InP和PreP指的是树最左边(这里递归是分左右树,左右的不相同)*/
void GetPostL( int PreP, int InP, int PostP, int n)
{
	if(n == 0) return;
	if(n == 1) PostL[PostP] ==  PreL[PreP];//三个点都相等 
	ElementType Root;//先找到根,前序遍历的第一个节点
	int i,L,R;
	Root = PreL[PreP]; 
	PostL[PostP + n - 1] = Root;
	for(i = 0; i < n; i++)
		if(Root == InL[InP + i]) break; 
	L = i;//左字数节点数 
	R = n - L - 1;//右子树节点数
	/* 左子树遍历 */
	GetPostL( PreP + 1, InP, PostP, L); 
	/* 右子树遍历 */ 
	GetPostL( PreP + L + 1, InP + L + 1, PostP + L, R);
}

  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值