poj 1308 入门(坑)

点击打开链接

Is It A Tree?
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 34232 Accepted: 11606

Description

A tree is a well-known data structure that is either empty (null, void, nothing) or is a set of one or more nodes connected by directed edges between nodes satisfying the following properties. 

There is exactly one node, called the root, to which no directed edges point. 
Every node except the root has exactly one edge pointing to it. 
There is a unique sequence of directed edges from the root to each node. 
For example, consider the illustrations below, in which nodes are represented by circles and edges are represented by lines with arrowheads. The first two of these are trees, but the last is not. 

In this problem you will be given several descriptions of collections of nodes connected by directed edges. For each of these you are to determine if the collection satisfies the definition of a tree or not.

Input

The input will consist of a sequence of descriptions (test cases) followed by a pair of negative integers. Each test case will consist of a sequence of edge descriptions followed by a pair of zeroes Each edge description will consist of a pair of integers; the first integer identifies the node from which the edge begins, and the second integer identifies the node to which the edge is directed. Node numbers will always be greater than zero.

Output

For each test case display the line "Case k is a tree." or the line "Case k is not a tree.", where k corresponds to the test case number (they are sequentially numbered starting with 1).

Sample Input

6 8  5 3  5 2  6 4
5 6  0 0

8 1  7 3  6 2  8 9  7 5
7 4  7 8  7 6  0 0

3 8  6 8  6 4
5 3  5 6  5 2  0 0
-1 -1

Sample Output

Case 1 is a tree.
Case 2 is a tree.
Case 3 is not a tree.
这个题奇坑无比,wa的我怀疑人生,让你判断输入的点连起来的东西是不是树,思路很简单,套路却不简单,0 0竟然也是一棵树!!!!,可用并查集,判断输入点集是否联通,非联通肯定不是,再判断会不会形成环,形成环也不是树。

并查集:

#include<cstdio>
#include<cstring>
#include<vector>
using namespace std;
int per[1001];
vector<int>a;
int flag,k=0;
int find(int i)
{
	while(i!=per[i])
	i=per[i];
	return i;
}
void link(int x,int y)
{
	x=find(x);
	y=find(y);
	if(x==y)
	flag=0;//如果x和y间接链接,则形成环 
	per[x]=y;
}
void clear()
{
	flag=1;
	a.clear();
	for(int i=0;i<1001;i++)
	per[i]=i;
}
int main()
{
	int u,v;
	while(~scanf("%d%d",&u,&v)&&u!=-1&&v!=-1)
	{
		if(u+v==0)
		{
			printf("Case %d is a tree.\n",++k);
			continue;
		}
		clear();
		a.push_back(u);//将输入点集存起来 
		a.push_back(v);
		link(u,v);
		while(~scanf("%d%d",&u,&v)&&u&&v)
		{
			link(u,v);	
			a.push_back(u);
			a.push_back(v);
		}
		if(!flag)
		{
			printf("Case %d is not a tree.\n",++k);
			continue;		
		}
		int temp=find(a[0]);
		for(int i=0;i<a.size();i++)
		if(find(a[i])!=temp)//判断点集是否联通 
		{
			flag=0;
			break;
		}
		if(flag)
		printf("Case %d is a tree.\n",++k);	
		else
		printf("Case %d is not a tree.\n",++k);
	}
}

树的性质(节点比边数多一):

#include<stdio.h>
#include<string.h>
int vis[1001];
int k=0;
int main()
{
	int u,v;
	while(~scanf("%d%d",&u,&v)&&u!=-1&&v!=-1)
	{
		if(u+v==0)
		{
			printf("Case %d is a tree.\n",++k);
			continue;
		}
		memset(vis,0,sizeof(vis));
		int sum=0,T=1;
		if(!vis[u])
		sum++;
		vis[u]=1;
		if(!vis[v])
		sum++;
		vis[v]=1;
		while(~scanf("%d%d",&u,&v)&&u&&v)
		{
			if(!vis[u])
			{
				sum++;
				vis[u]=1;
			}
			if(!vis[v])
			{
				sum++;
				vis[v]=1;
			}	
			T++;
		}
		if(sum==T+1)
		printf("Case %d is a tree.\n",++k);
		else
		printf("Case %d is not a tree.\n",++k);
	}
}


评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

长沙橘子猫

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值