4.22-railway ticket -动态规划

总时间限制:
1000ms
内存限制:
65536kB

描述
The railway line “Ekaterinburg-Sverdlovsk” with several stations has been built. This railway line can be represented as a line segment, railway stations being points on it. The railway line starts at the station “Ekaterinburg” and finishes at the station “Sverdlovsk”, so stations are numbered starting from “Ekaterinburg” (it has number 1) and “Sverdlovsk” is the last station.

Cost of the ticket between any two stations depends only on a distance between them. The prices for the tickets are specified in the following table.

distance between stations -X


price for the ticket

0<X<=L1


C1

L1<X<=L2


C2

L2<X<=L3


C3

Direct tickets from one station to another can be booked if and only if the distance between these station does not exceed L3. So sometimes it is necessary to book several tickets to pay for the parts of the whole way between stations.

For example, on the railway line shown at the figure above there are seven stations. The direct ticket from the second station to the sixth one can not be booked. There are several ways to pay for the travel between these stations. One of them is to book two tickets: one ticket at price C2 to travel between the second and the third stations, and other at price C3 to travel between the third and the sixth stations. Note, that though the distance between the second and the sixth stations is equal to 2*L2, the whole travel can not be paid by booking two tickets at price C2, because each ticket is valid for only one travel and each travel should start and end only at stations.

Your task is to write a program, that will find the minimal cost of the travel between two given stations.

输入
The first line of the input file contains 6 integers L1, L2, L3, C1, C2, C3 (1 <= L1 < L2 < L3 <= 10^9, 1 <= C1 < C2 < C3 <= 10^9) in the specified order with one space between. The second line contains the amount of stations N (2 <= N <= 10000). The third line contains two different integers separated by space. They represent serial numbers of stations, the travel between which must be paid. Next N-1 lines contain distances from the first station (“Ekaterinburg”) on the railway line to others. These distances are given as different positive integers and are arranged in the ascending order. The distance from “Ekaterinburg” to “Sverdlovsk” does not exceed 10^9. The distance between any neighboring stations does not exceed L3. The minimal travel cost between two given stations will not exceed 10^9.
输出
Program should print to the output file the only number, which is the minimal travel cost between two given stations.
样例输入

3 6 8 20 30 40
7
2 6
3
7
8
13
15
23

样例输出

70

这道题应该想到跳台阶的问题!
建立递推关系动态规划

#include<iostream>
using namespace std;
int a[10001];
int dp[10001];
int main()
{
    int l1,l2,l3;
    int c1,c2,c3;
    cin>>l1>>l2>>l3;
    cin>>c1>>c2>>c3;
    int n;
    cin>>n;
    int ai,b;
    cin>>ai>>b;
    for(int i=2;i<=n;i++)
    {
        cin>>a[i];
    }
    for(int i=ai+1;i<=b;i++)
    {
        int currmin;
        for(int j=i-1;j>=ai;j--)
        {
            int tem=a[i]-a[j];
            if(tem>l3)
            {
                break;
            }
            if(tem>0&&tem<=l1)
            {
                if(j==i-1)
                {
                    currmin=c1+dp[j];
                }
                else{
                    currmin=min(currmin,c1+dp[j]);
                }
            }
            if(tem>l1&&tem<=l2)
            {
                if(j==i-1)
                {
                    currmin=c2+dp[j];
                }
                else{
                    currmin=min(currmin,c2+dp[j]);
                }
            }
            if(tem>l2&&tem<=l3)
            {
                if(j==i-1)
                {
                    currmin=c3+dp[j];
                }
                else{
                    currmin=min(currmin,c3+dp[j]);
                }
            }
        }
        dp[i]=currmin;
    }
    cout<<dp[b];
} 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值