2015-06-28 14:52:23 OJ期末模考D

Problem D: E2 驾驭const

Time Limit: 1 Sec  Memory Limit: 128 MB
Submit: 550  Solved: 386
[Submit][Status][Web Board]

Description

引入了const关键词,用于指定对象及对象成员,提供了对数据的一种保护机制,这C++语言的特色之一。但由此,也引出了一些语法上的要求。这些语法要求,实际上有一套完善的原则,需要熟知。

下面的程序,要利用输入的两个数创建一个对象,并调用printxy成员函数输入两数之和。下面的程序中,beginend部分需要改动三处,才能保证程序符合要求并正确输出。请你找出并修改过来,提交beginend部分的代码。

#include <iostream>

using namespace std;

class Test

{

private:

    int x;

    const int y;

//************* begin *****************

public:

    Test(int a, int b);

    void printxy();   //(1)

} ;

Test::Test(int a, int b){x=a;y=b;}  //(2)

void Test::printxy()   //(3)

{

    cout<<"x*y="<<x*y<<endl;

}

//************* end *****************

int main()

{

    int x1,x2;

    cin>>x1>>x2;

    const Test t(x1,x2);

    t.printxy( );

    return 0;

}

Input

两个整数,以空格分开

Output

两数的乘积

Sample Input

3 5

Sample Output

x*y=15

 

 

Submit:

#include <iostream>
using namespace std;
class Test
{
private:
    int x;
    const int y;
//************* begin *****************
public:
    Test(int a, int b);
    void printxy() const;   //(1)
} ;
Test::Test(int a, int b):x(a),y(b){}  //(2)
void Test::printxy() const   //(3)
{
    cout<<"x*y="<<x*y<<endl;
}
//************* end *****************
int main()
{
    int x1,x2;
    cin>>x1>>x2;
    const Test t(x1,x2);
    t.printxy( );
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值