HDOJ5115 Dire Wolf(区间dp) ——2014北京现场赛D题

25 篇文章 0 订阅
24 篇文章 0 订阅
Problem Description
Dire wolves, also known as Dark wolves, are extraordinarily large and powerful wolves. Many, if not all, Dire Wolves appear to originate from Draenor.
Dire wolves look like normal wolves, but these creatures are of nearly twice the size. These powerful beasts, 8 - 9 feet long and weighing 600 - 800 pounds, are the most well-known orc mounts. As tall as a man, these great wolves have long tusked jaws that look like they could snap an iron bar. They have burning red eyes. Dire wolves are mottled gray or black in color. Dire wolves thrive in the northern regions of Kalimdor and in Mulgore.
Dire wolves are efficient pack hunters that kill anything they catch. They prefer to attack in packs, surrounding and flanking a foe when they can.
— Wowpedia, Your wiki guide to the World of Warcra

Matt, an adventurer from the Eastern Kingdoms, meets a pack of dire wolves. There are N wolves standing in a row (numbered with 1 to N from left to right). Matt has to defeat all of them to survive.

Once Matt defeats a dire wolf, he will take some damage which is equal to the wolf’s current attack. As gregarious beasts, each dire wolf i can increase its adjacent wolves’ attack by b i. Thus, each dire wolf i’s current attack consists of two parts, its basic attack ai and the extra attack provided by the current adjacent wolves. The increase of attack is temporary. Once a wolf is defeated, its adjacent wolves will no longer get extra attack from it. However, these two wolves (if exist) will become adjacent to each other now.

For example, suppose there are 3 dire wolves standing in a row, whose basic attacks ai are (3, 5, 7), respectively. The extra attacks b i they can provide are (8, 2, 0). Thus, the current attacks of them are (5, 13, 9). If Matt defeats the second wolf first, he will get 13 points of damage and the alive wolves’ current attacks become (3, 15).

As an alert and resourceful adventurer, Matt can decide the order of the dire wolves he defeats. Therefore, he wants to know the least damage he has to take to defeat all the wolves.
 

Input
The first line contains only one integer T , which indicates the number of test cases. For each test case, the first line contains only one integer N (2 ≤ N ≤ 200).

The second line contains N integers a i (0 ≤ a i ≤ 100000), denoting the basic attack of each dire wolf.

The third line contains N integers b i (0 ≤ b i ≤ 50000), denoting the extra attack each dire wolf can provide.
 

Output
For each test case, output a single line “Case #x: y”, where x is the case number (starting from 1), y is the least damage Matt needs to take.
 

Sample Input
  
  
2 3 3 5 7 8 2 0 10 1 3 5 7 9 2 4 6 8 10 9 4 1 2 1 2 1 4 5 1
 

Sample Output
  
  
Case #1: 17 Case #2: 74
Hint
In the first sample, Matt defeats the dire wolves from left to right. He takes 5 + 5 + 7 = 17 points of damage which is the least damage he has to take.

题意:有n匹狼排成一排,每匹狼都有一个自身的攻击力,还有一个对左右两个同伴的协助攻击力。当你要杀一匹狼时,不仅会受到等于它攻击力的伤害,还会受到等于它左右两个同伴的协助伤害(如果有)。给这n匹狼的自身攻击力和协助攻击力,让你选择一个灭掉这n匹狼的顺序,使得受到的伤害最小。

对于自身攻击力造成的伤害,我们只需要将它们相加起来就好,这个不会多也不会少。

需要考虑的是协助性伤害。

d[i][j]表示杀掉区间[i,j]的狼受到的最小伤害。

则d[i][j] = min { d[i][k-1]+d[k+1][j] } + b[i-1] + b[j+1]

其中i<=k<=j,表示此区间最后杀掉的一匹狼。 b[i]表示第i匹狼的协助攻击力。


#include<iostream>
#include<algorithm>
#include<cstdio>
#include<cstring>
#include<cmath>
using namespace std;
typedef long long int64;
#define rep(i,f,t) for(int i = (f); i <= (t); ++i)
#define debug(x) cout<<"debug  "<<x<<endl;
int a[300];
int b[300];
int64 d[300][300];
int n;
int64 solve(){
    b[n+1] = 0;
    memset(d,0,sizeof(d));
    for(int i = n; i > 0; --i){
        d[i][i] = b[i-1] + b[i+1];
        for(int j = i+1; j <= n; ++j){
            int64 tmp = 1e15;
            rep(k,i,j){
                int64 tmp2 = d[i][k-1] + d[k+1][j];
                tmp = min(tmp,tmp2);
            }
            d[i][j] = tmp + b[i-1] + b[j+1];
        }
    }
    return d[1][n];
}
int main(){
    int T;
    scanf("%d",&T);
    int cas = 0;
    while(T--){
        scanf("%d",&n);
        for(int i = 1; i <= n; ++i)scanf("%d",&a[i]);
        for(int i = 1; i <= n; ++i)scanf("%d",&b[i]);
        int64 s = 0;
        for(int i = 1; i <= n; ++i)s += a[i];
        int64 ans = solve();
        printf("Case #%d: %lld\n",++cas,ans+s);
    }
    return 0;
}




  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值