HDOJ4432 Sum of divisors(暴力)

24 篇文章 0 订阅
2 篇文章 0 订阅
Problem Description
mmm is learning division, she's so proud of herself that she can figure out the sum of all the divisors of numbers no larger than 100 within one day!
But her teacher said "What if I ask you to give not only the sum but the square-sums of all the divisors of numbers within hexadecimal number 100?" mmm get stuck and she's asking for your help.
Attention, because mmm has misunderstood teacher's words, you have to solve a problem that is a little bit different.
Here's the problem, given n, you are to calculate the square sums of the digits of all the divisors of n, under the base m.
 


 

Input
Multiple test cases, each test cases is one line with two integers.
n and m.(n, m would be given in 10-based)
1≤n≤10 9
2≤m≤16
There are less then 10 test cases.
 


 

Output
Output the answer base m.
 


 

Sample Input
  
  
10 2 30 5
 


 

Sample Output
  
  
110 112
Hint
Use A, B, C...... for 10, 11, 12...... Test case 1: divisors are 1, 2, 5, 10 which means 1, 10, 101, 1010 under base 2, the square sum of digits is 1^2+ (1^2 + 0^2) + (1^2 + 0^2 + 1^2) + .... = 6 = 110 under base 2.

 

题意: 给两个数n和m,对于n的每一个约数k,求k在m进制下的每一个数字的平方和, 再将所有平方和相加起来,用m进制输出。

题目怎么说就怎么做,简单粗暴。

 

#include<iostream>
#include<cstdio>
#include<cmath>
#include<algorithm>
#include<string>
#include<stack>
using namespace std;
#define rep(i,f,t) for(int i = (f), _end = (t); i <= _end; ++i)
typedef long long int64;
#define debug(x) cout<<"debug   "<<x<<endl;
const int maxn = 1000000000+5;
int n,m;
string jz = "0123456789ABCDEF";

int64 gao(int i){
    int64 ans = 0;
    while(i){
        int tmp = i%m;
        i /= m;
        ans += tmp*tmp;
    }
    return ans;
}

void out(int64 ans){
    stack<char> s;
    while(ans){
        int tmp = ans%m;
        ans /= m;
        s.push(jz[tmp]);
    }
    while(!s.empty()){
        printf("%c",s.top());
        s.pop();
    }
    printf("\n");
    return ;
}
int main(){
    while( scanf("%d%d",&n,&m) == 2){
        int ans = 0;
        double sn = sqrt(n);
        if((int)sn*(int)sn == n)ans = gao(sn);
        for(int i = 1; i < sn; ++i){
            if(n%i)continue;
            ans += gao(i);
            ans += gao(n/i);
        }
        out(ans);
    }
    return 0;
}


 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值