[C++] TeX中的引号

[C++] TeX中的引号

题目

在TeX中,左双引号是“``”,右双引号是“’’”。输入一篇包含双引号的文章,你的任务是把它转换成TeX的格式。

样例输入:

“To be or not to be,” quoth the Bard, “that is the question”.

样例输出:

``To be or not to be,’’ quoth the Bard, ``that is the question’’.

分析

本题以回车结束输入。

代码实现

#include <iostream>
#include <string>  
using namespace std;

int main()
{
    string str;
    getline(cin, str);   //接收包含空格的字符串
    int n = str.length(), m = 0;
    for(int i = 0; i < n; i++)
    {
        if(str[i] == '"'){
            if(m == 0)
                cout<<"``";
            else
                cout<<"''";
            m = !m;
        }
        else
            cout<<str[i];
    }
    return 0;
}
  • 0
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值