1015. Reversible Primes

reversible prime in any number system is a prime whose "reverse" in that number system is also a prime. For example in the decimal system 73 is a reversible prime because its reverse 37 is also a prime.

Now given any two positive integers N (< 105) and D (1 < D <= 10), you are supposed to tell if N is a reversible prime with radix D.

Input Specification:

The input file consists of several test cases. Each case occupies a line which contains two integers N and D. The input is finished by a negative N.

Output Specification:

For each test case, print in one line "Yes" if N is a reversible prime with radix D, or "No" if not.

Sample Input:
73 10
23 2
23 10
-2
Sample Output:
Yes
Yes
No
/* 
题目的意思是给定数10进制数N和进制D,将N转化成D进制, 
再将D进制的数反转,最后转化为10进制数M,判断N和M是否都是质素。 
*/ 
#include<iostream>
#include<string>
#include<math.h>
#include<vector>
using namespace std;
bool IsPrime(int n)
{
	if(n<2)
		return false;
	for(int i=2;i<=sqrt(n);++i)//必须是<=才是求素数
	{
		if(n%i==0)
			return false;
	}
	return true;
}
int ReverseNumber(int s,int radix)
{
	int num[100],cnt=0;
	int sum=0;
	while(s)
	{
		num[cnt++]=s%radix;
		s=s/radix;
	}
	for(int i=0;i<cnt;++i)
	{
		sum*=radix;
		sum+=num[i];
	}
	return sum;
}
			
int main()
{
	int s,radix;
	while(cin>>s>>radix)
	{
		if(radix<0)
			break;
		if(IsPrime(s)&&IsPrime(ReverseNumber(s,radix)))
			cout<<"Yes"<<endl;
		else
			cout<<"No"<<endl;
	}
	return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值