03-树2. List Leaves (25) Java

03-树2. List Leaves (25)

时间限制
400 ms
内存限制
65536 kB
代码长度限制
8000 B
判题程序
Standard
作者
CHEN, Yue
Given a tree, you are supposed to list all the leaves in the order of top down, and left to right.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (<=10) which is the total number of nodes in the tree -- and hence the nodes are numbered from 0 to N-1. Then N lines follow, each corresponds to a node, and gives the indices of the left and right children of the node. If the child does not exist, a "-" will be put at the position. Any pair of children are separated by a space.

Output Specification:

For each test case, print in one line all the leaves' indices in the order of top down, and left to right. There must be exactly one space between any adjacent numbers, and no extra space at the end of the line.

Sample Input:
8
1 -
- -
0 -
2 7
- -
- -
5 -
4 6
Sample Output:
4 1 5


解:
import java.util.LinkedList;
import java.util.Queue;
import java.util.Scanner;


class Node 
{

	int left=-1;
	int right=-1;
	public Node() {
		super();
	}
}


public class Main{

	

	
/**

*(方法说明)

*@param  无

*@return 无

*@throws 无

*/
public static void main(String[] args){
	
	Node[] nodes = new Node[11];//节点
	//n个节点
	Scanner scanner = new Scanner(System.in);
	int n= scanner.nextInt();
	int child[] = new int[10];
	int root = 0 ; //根
	//构建树
	for(int i=0;i<n;i++)
	{
		Node node = new Node();
		char left = scanner.next().charAt(0);
		char right = scanner.next().charAt(0);
	
		if(!(left=='-'))
		{
			node.left=left-'0';
			child[left-'0']++;
		}
		if(!(right=='-'))
		{
			node.right=right-'0';
			child[right-'0']++;
		}
		nodes[i] = node;
	}
	
	//寻找根
	for(int i=0;i<n;i++)
	{
		if(child[i]==0)
		{
			root = i;
			break;
		}
	}
	
	Queue<Integer> queue = new LinkedList<Integer>();
	boolean firstPrintNode = true;
	queue.offer(root);
	while(!queue.isEmpty())
	{
		int currenNode = queue.poll();
	//	System.out.print("currenNode:"+currenNode);
		if(nodes[currenNode].left==-1 && nodes[currenNode].right==-1)
		{
			if(firstPrintNode)
			{
				System.out.print(currenNode);
				firstPrintNode=false;
			}
			else 
				System.out.print(" "+currenNode);
		}
		if(nodes[currenNode].left!=-1)
		{
		
			queue.offer(nodes[currenNode].left);
		}
		if(nodes[currenNode].right!=-1)
		{
			queue.offer(nodes[currenNode].right);
		}
	}
	
}



	
}
  



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值