POJ2421 Constructing Roads

                                                                                   Constructing Roads
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 10239 Accepted: 4010

Description

There are N villages, which are numbered from 1 to N, and you should build some roads such that every two villages can connect to each other. We say two village A and B are connected, if and only if there is a road between A and B, or there exists a village C such that there is a road between A and C, and C and B are connected.

We know that there are already some roads between some villages and your job is the build some roads such that all the villages are connect and the length of all the roads built is minimum.

Input

The first line is an integer N (3 <= N <= 100), which is the number of villages. Then come N lines, the i-th of which contains N integers, and the j-th of these N integers is the distance (the distance should be an integer within [1, 1000]) between village i and village j.

Then there is an integer Q (0 <= Q <= N * (N + 1) / 2). Then come Q lines, each line contains two integers a and b (1 <= a < b <= N), which means the road between village a and village b has been built.

Output

You should output a line contains an integer, which is the length of all the roads to be built such that all the villages are connected, and this value is minimum.

Sample Input

3
0 990 692
990 0 179
692 179 0
1
1 2

Sample Output

179

这是今天我写的第四个关于最小生成树的题目,只有这个题目有点变化。但是其中有一个处理,就是将已经建立的村庄的权值修改为0,但是又不与d[i][i]0处理不一样。修改后的权值与没有修改的权值一起处理,将d[i][i]与这些分开处理。

AC程序如下:

#include<iostream>

#include<cstring>

using namespace std;

int q,n,d[101][101];

int v[101];

int main()

{

    while(cin>>n)

    {

         int a,b,i,j,m,t,best=0;

         for(i=1;i<=n;i++)

             for(j=1;j<=n;j++)

                cin>>d[i][j];

         cin>>q;

         memset(v,0,sizeof(v));

         int t1=1;

         for(i=1;i<=q;i++)

         {

               cin>>a>>b;

               d[a][b]=d[b][a]=0;       

         } 

         v[1]=1;      

         while(t1<n)

         {

            m=111111;       

            for(i=1;i<=n;i++)

            {             

               for(j=1;j<=n;j++)

               {

                  if(i==j) continue;                       

                  if(!v[i]&&v[j]&&d[i][j]<m)

                  {

                                                 

                       m=d[i][j];

                       t=i;

                       //cout<<t<<endl;

                  }

               }

            }

            //cout<<1<<endl;

            v[t]=1;

            best+=m;

            //cout<<t<<" "<<best<<endl;

            t1++;

         }

         cout<<best<<endl;

    }

    return 0;

}                                                                  

 

评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值