1136: HH生病了
Time Limit: 1 Sec Memory Limit: 128 MBSubmit: 324 Solved: 90
[ Submit][ Status][ Web Board] [ Edit]
Description
HH很不幸的感冒了,只好去校医院去挂盐水,挂盐水的时候,他发现盐水滴起来有规律,先是滴一滴,停一下;然后滴二滴,停一 下;再滴三滴,停一下...,现在有一个问题:这瓶盐水一共有VUL毫升,每一滴是D毫升,每一滴的速度是一秒(假设最后一滴不到D毫升,则花费的时间也 算一秒),停一下的时间也是一秒这瓶水什么时候能挂完呢?
Input
输入数据占一行,由VUL和D组成,其中0< D< VUL< 5000。
Output
请输出挂完盐水需要的时间。
Sample Input
10 1
Sample Output
13
HINT
Source
WA了12次。。差点崩溃-_-!
#include <stdio.h>
#include <string.h>
#include <math.h>
int main() {
double V, D;
int a, b, ans, i, j;
while (scanf("%lf%lf", &V, &D) != EOF) {
a = V / D;
if (V - a * D > 0.0) ++a;
for (i = 1, ans = a; a > 0; ++i) {
a -= i;
if(a > 0) ++ans;
}
printf("%ld\n", ans);
}
return 0;
}
/**************************************************************
Problem: 1136
User: changmu
Language: C
Result: Accepted
Time:0 ms
Memory:768 kb
****************************************************************/