eclipse配置tomcat8.5

在eclipse中,当使用tomcat版本为8.5时(一个神奇的版本),无法与eclipse绑定,选择8.0或9.0版本都会提示:


The Apache Tomcat installation at this directory is version 8.5.5.  A Tomcat 8.0 installation is expected.


如下图:




2种解决办法

1. 人肉修改tomcat的版本号

1.使用WinRar, WinZip, 7zip打开文件./lib/catalina.jar (注意不要解压)
2.打开文件org/apache/catalina/util/ServerInfo.properties
3.修改文件第16行版本号为 8.0.0
4.保存,将文件更新到原jar包中即可


成功绑定:



2.打补丁:

https://bugs.eclipse.org/bugs/attachment.cgi?id=262418&action=edit

Download this patch and put it to the plugins directory of your Eclipse installation. It will replace the default "org.eclipse.jst.server.tomcat.core_1.1.800.v201602282129.jar".


详细可参考:《How to use Tomcat 8.5.x and TomEE 7.x with Eclipse?




已标记关键词 清除标记
相关推荐
©️2020 CSDN 皮肤主题: 编程工作室 设计师:CSDN官方博客 返回首页