PAT甲级 1023. Have Fun with Numbers (20)

题目:

Notice that the number 123456789 is a 9-digit number consisting exactly the numbers from 1 to 9, with no duplication. Double it we will obtain 246913578, which happens to be another 9-digit number consisting exactly the numbers from 1 to 9, only in a different permutation. Check to see the result if we double it again!

Now you are suppose to check if there are more numbers with this property. That is, double a given number with k digits, you are to tell if the resulting number consists of only a permutation of the digits in the original number.

Input Specification:

Each input file contains one test case. Each case contains one positive integer with no more than 20 digits.

Output Specification:

For each test case, first print in a line "Yes" if doubling the input number gives a number that consists of only a permutation of the digits in the original number, or "No" if not. Then in the next line, print the doubled number.

Sample Input:
1234567899
Sample Output:
Yes
2469135798
思路:

这题很简单,读取字符串,做乘法并统计数字个数。注意一下进位就好了。

代码:

这程序写得有些繁琐,但还是通过了。

#include<iostream>
#include<string>
#include<vector>
using namespace std;

int main()
{
	int digit[10] = { 0 };
	int digit2[10] = { 0 };
	//input
	string s;
	cin >> s;
	vector<int> d_s;
	int i;
	int d1,d2;
	int tmp = 0;
	for (i = s.size() - 1; i >= 0; --i)
	{
		d1 = s[i] - '0';
		digit[d1]++;
		d2 = (d1 * 2+tmp) % 10;
		tmp = (d1 * 2 + tmp) / 10;
		d_s.push_back(d2);
		digit2[d2]++;
	}
	if (tmp != 0)
	{
		d_s.push_back(tmp);
		digit2[tmp]++;
	}
	int flag = 0;
	for (i = 0; i <= 9; ++i)
	{
		if (digit[i] != digit2[i])
			flag++;
		if (flag > 0)
			break;
	}
	if (flag > 0)
		cout << "No" << endl;
	else
		cout << "Yes" << endl;
	for (i = d_s.size() - 1; i >= 0; --i)
		cout << d_s[i];
	cout << endl;
	system("pause");
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值