PAT甲级 1044. Shopping in Mars (25)

题目:

Shopping in Mars is quite a different experience. The Mars people pay by chained diamonds. Each diamond has a value (in Mars dollars M$). When making the payment, the chain can be cut at any position for only once and some of the diamonds are taken off the chain one by one. Once a diamond is off the chain, it cannot be taken back. For example, if we have a chain of 8 diamonds with values M$3, 2, 1, 5, 4, 6, 8, 7, and we must pay M$15. We may have 3 options:

1. Cut the chain between 4 and 6, and take off the diamonds from the position 1 to 5 (with values 3+2+1+5+4=15).
2. Cut before 5 or after 6, and take off the diamonds from the position 4 to 6 (with values 5+4+6=15).
3. Cut before 8, and take off the diamonds from the position 7 to 8 (with values 8+7=15).

Now given the chain of diamond values and the amount that a customer has to pay, you are supposed to list all the paying options for the customer.

If it is impossible to pay the exact amount, you must suggest solutions with minimum lost.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 numbers: N (<=105), the total number of diamonds on the chain, and M (<=108), the amount that the customer has to pay. Then the next line contains N positive numbers D1 ... DN (Di<=103 for all i=1, ..., N) which are the values of the diamonds. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print "i-j" in a line for each pair of i <= j such that Di + ... + Dj = M. Note that if there are more than one solution, all the solutions must be printed in increasing order of i.

If there is no solution, output "i-j" for pairs of i <= j such that Di + ... + Dj > M with (Di + ... + Dj - M) minimized. Again all the solutions must be printed in increasing order of i.

It is guaranteed that the total value of diamonds is sufficient to pay the given amount.

Sample Input 1:
16 15
3 2 1 5 4 6 8 7 16 10 15 11 9 12 14 13
Sample Output 1:
1-5
4-6
7-8
11-11
Sample Input 2:
5 13
2 4 5 7 9
Sample Output 2:
2-4
4-5
思路:

1.这道题最简单的思路是利用遍历来查找,但是有3个测试点未通过。因为在计算当从第i+1个点开始计算时,有一部分是第i个点已经计算过的,相当于重复计算。所以,在新的程序中,当前坐标i于后坐标j之间的数总和:

  1)小于M时,后坐标j后移,直至总和大于等于M或达到最后一位

  2)大于M时,则前坐标i后移,直至总和小于M或达到后坐标j,这里要注意得到i还要前移,减一位。

  3)等于M时,进行标记

2.即使重新改进程序,仍有测试点未通过,这时应该用scanf和printf来替换cin和cout。

代码:

#include<iostream>
#include<vector>
using namespace std;

struct sol
{
	int begin;
	int end;
};
vector<sol> solution;
int min_pay = 0;
void addsolution(int i, int j, int pay)
{
	sol tmp;
	tmp.begin = i;
	tmp.end = j;
	if (solution.size() == 0)
	{
		min_pay = pay;
		solution.push_back(tmp);
	}
	else
	{
		if (pay < min_pay)
		{
			solution.clear();

			min_pay = pay;
			solution.push_back(tmp);
		}
		else
		{
			if (pay == min_pay)
			{
				solution.push_back(tmp);
			}
		}
	}
};

int main()
{
	int N, M;
	cin >> N >> M;

	int chain[100001] = { 0 };
	int i, j;
	for (i = 1; i <= N; ++i)
	{
		scanf("%d", &chain[i]);
	}

	i = 1; j = 0;
	int pay = 0;

	while (i <= N && j <= N)
	{
		if (pay < M)
		{
			//当前范围小于M,后坐标后移
			while (pay < M && j < N) {
				++j;
				pay += chain[j];
			}
			//考虑到可能会有j==N,但pay<M的情况
			if (pay >= M)
			{
				addsolution(i, j, pay);
			}
			pay -= chain[i];
			++i;

		}
		else
		{
			if (pay > M)
			{
				//当前范围大于M,前坐标后移
				while (pay > M && i < j)
				{
					pay -= chain[i];
					++i;
				}				
				if (pay < M)
				{
					--i;
					pay += chain[i];
				}			
			}
			addsolution(i, j, pay);
			++j;
			pay += chain[j];
		}

	}

	for (i = 0; i < solution.size(); ++i)
	{		
		printf("%d-%d\n", solution[i].begin, solution[i].end);
	}

	system("pause");
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值