POJ-1005 和 c++ π 的使用

这个英文问题描述我看了好久才看懂

I Think I Need a Houseboat

Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 114175 Accepted: 49288

Description

Fred Mapper is considering purchasing some land in Louisiana to build his house on. In the process of investigating the land, he learned that the state of Louisiana is actually shrinking by 50 square miles each year, due to erosion caused by the Mississippi River. Since Fred is hoping to live in this house the rest of his life, he needs to know if his land is going to be lost to erosion. 

After doing more research, Fred has learned that the land that is being lost forms a semicircle. This semicircle is part of a circle centered at (0,0), with the line that bisects the circle being the X axis. Locations below the X axis are in the water. The semicircle has an area of 0 at the beginning of year 1. (Semicircle illustrated in the Figure.) 

                                                        

Input

The first line of input will be a positive integer indicating how many data sets will be included (N). Each of the next N lines will contain the X and Y Cartesian coordinates of the land Fred is considering. These will be floating point numbers measured in miles. The Y coordinate will be non-negative. (0,0) will not be given.

Output

For each data set, a single line of output should appear. This line should take the form of: “Property N: This property will begin eroding in year Z.” Where N is the data set (counting from 1), and Z is the first year (start from 1) this property will be within the semicircle AT THE END OF YEAR Z. Z must be an integer. After the last data set, this should print out “END OF OUTPUT.”

Sample Input

2
1.0 1.0
25.0 0.0

Sample Output

Property 1: This property will begin eroding in year 1.
Property 2: This property will begin eroding in year 20.
END OF OUTPUT.

Hint

1.No property will appear exactly on the semicircle boundary: it will either be inside or outside. 
2.This problem will be judged automatically. Your answer must match exactly, including the capitalization, punctuation, and white-space. This includes the periods at the ends of the lines. 
3.All locations are given in miles.

 

大概的意思是:

有个半圆形的区域,会被河水侵蚀,每年侵蚀50平方英里

输入第一行:N        //接下来会有N个x,y坐标值

接下来N行: x y

输出:第几年点会被淹没

思路

思路一:

因为它是个圆形,在侵蚀面积增加的时候x,y增加的长度一样,只用比较侵蚀到这个点需要的面积逐年总的递增的面积大小,哪一年递增的面积超过侵蚀这个点需要的面积,就是这一年

但是这个思路会引入两层for嵌套

思路二:

这个点需要的面积(need_area),需要的年数(need_year)

need_year = [ need_area  /  50 ] + 1                //[ ] 表示取整

思路一代码

#include<iostream>
using namespace std;
#define _USE_MATH_DEFINES
#include<math.h>

#define N 500

int main()
{
	int line;	//行数N
	double coordinates[N][2];	//存储每行的坐标信息
	cin >> line;
	for (int i = 0; i < line; i++)
	{
		cin >> coordinates[i][0] >> coordinates[i][1];
	}
	for (int i = 0; i < line; i++)
	{
		double need_area = 0.5*M_PI*(pow(coordinates[i][0],2) + pow(coordinates[i][1],2));	//需要的面积,半圆乘以0.5
		double eroding_area = 0;		//现在已经侵蚀的的面积
		for (int j = 1;; j++)
		{
			eroding_area += 50;
			if (need_area <= eroding_area)//需要的面积小于侵蚀的面积
			{
				cout << "Property " << (i + 1) << ": This property will begin eroding in year " << j << "." << endl;
				break;	//找到了就退出这层循环
			}
		}
	}
	cout << "END OF OUTPUT.";
	return 0;
}

思路二代码:

#include<iostream>
using namespace std;
#define _USE_MATH_DEFINES
#include<math.h>

#define N 500

int main()
{
	int line;	//行数N
	double coordinates[N][2];	//存储每行的坐标信息
	cin >> line;
	for (int i = 0; i < line; i++)
	{
		cin >> coordinates[i][0] >> coordinates[i][1];
	}
	for (int i = 0; i < line; i++)
	{
		double need_area = 0.5*M_PI*(pow(coordinates[i][0],2) + pow(coordinates[i][1],2));	//需要的面积,半圆乘以0.5
		int need_year = int(need_area / 50) + 1;	//取整后加1
		cout << "Property " << (i + 1) << ": This property will begin eroding in year " << need_year << "." << endl;
	}
	cout << "END OF OUTPUT.";
	return 0;
}

 

 

π的使用:

_USE_MATH_DEFINES定义的数学常用数据:

使用的时候注意:一定要先写define后写include,不然会报错

                               #define _USE_MATH_DEFINES
                               #include<math.h>    //必须是math.h不能是cmath

C++ : _USE_MATH_DEFINES
By bkrtoni, history, 22 months ago,  In English,  Attach this blog to some contest as a resource
 #if defined(_USE_MATH_DEFINES) && !defined(_MATH_DEFINES_DEFINED)
#define _MATH_DEFINES_DEFINED

/* Define _USE_MATH_DEFINES before including math.h to expose these macro
 * definitions for common math constants.  These are placed under an #ifdef
 * since these commonly-defined names are not part of the C/C++ standards.
 */

/* Definitions of useful mathematical constants
 * M_E        - e
 * M_LOG2E    - log2(e)
 * M_LOG10E   - log10(e)
 * M_LN2      - ln(2)
 * M_LN10     - ln(10)
 * M_PI       - pi
 * M_PI_2     - pi/2
 * M_PI_4     - pi/4
 * M_1_PI     - 1/pi
 * M_2_PI     - 2/pi
 * M_2_SQRTPI - 2/sqrt(pi)
 * M_SQRT2    - sqrt(2)
 * M_SQRT1_2  - 1/sqrt(2)
 */

#define M_E        2.71828182845904523536
#define M_LOG2E    1.44269504088896340736
#define M_LOG10E   0.434294481903251827651
#define M_LN2      0.693147180559945309417
#define M_LN10     2.30258509299404568402
#define M_PI       3.14159265358979323846
#define M_PI_2     1.57079632679489661923
#define M_PI_4     0.785398163397448309616
#define M_1_PI     0.318309886183790671538
#define M_2_PI     0.636619772367581343076
#define M_2_SQRTPI 1.12837916709551257390
#define M_SQRT2    1.41421356237309504880
#define M_SQRT1_2  0.707106781186547524401

#endif  /* _USE_MATH_DEFINES */

 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值