HDU 1715-大菲波数(大数)

address:http://acm.hdu.edu.cn/showproblem.php?pid=1715

Problem Description
Fibonacci数列,定义如下:
f(1)=f(2)=1
f(n)=f(n-1)+f(n-2) n>=3。
计算第n项Fibonacci数值。

Input
输入第一行为一个整数N,接下来N行为整数Pi(1<=Pi<=1000)。

Output
输出为N行,每行为对应的f(Pi)。

Sample Input
5
1
2
3
4
5

Sample Output
1
1
2
3
5

code:

#include <iostream>
#include <string.h>
#include <cstdio>
using namespace std;

int main ()
{
    int i,j;
    int a[1001][301];
    memset(a,0,sizeof(a));
    a[1][0]=1;
    a[2][0]=1;
    int next=0,count=1;
    for (i=3;i<=1000;i++)
    {
        for (j=0;j<count;j++)
        {
            a[i][j] = a[i-1][j]+a[i-2][j]+next;
            next = a[i][j]/10;
            a[i][j] = a[i][j]%10;
        }
        while (next)
        {
            count++;
            a[i][count-1]=next%10;
            next = next/10;
        }
    }
    int n;
    cin>>n;
    while (n--)
    {
        int i;
        int x,flag=0;
        cin>>x;
        for (i=count;i>=0;i--)
        {
            if (a[x][i]==0&&flag==0)
                continue;
            else
            {
                flag=1;
                cout<<a[x][i];;
            }
        }
        cout<<endl;
    }
    return 0;
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值