HDU 3018-Ant Trip(并查集&&欧拉)

address: http://acm.hdu.edu.cn/showproblem.php?pid=3018

Problem Description
Ant Country consist of N towns.There are M roads connecting the towns.

Ant Tony,together with his friends,wants to go through every part of the country.

They intend to visit every road , and every road must be visited for exact one time.However,it may be a mission impossible for only one group of people.So they are trying to divide all the people into several groups,and each may start at different town.Now tony wants to know what is the least groups of ants that needs to form to achieve their goal.

Input
Input contains multiple cases.Test cases are separated by several blank lines. Each test case starts with two integer N(1<=N<=100000),M(0< =M<=200000),indicating that there are N towns and M roads in Ant Country.Followed by M lines,each line contains two integers a,b,(1<=a,b<=N) indicating that there is a road connecting town a and town b.No two roads will be the same,and there is no road connecting the same town.

Output
For each test case ,output the least groups that needs to form to achieve their goal.

Sample Input
3 3
1 2
2 3
1 3

4 2
1 2
3 4

Sample Output
1
2

其实 题目多的意思 就是 几笔画问题, 问走一次 可以将所有点走完

首先,你用笔来画的话,只可能有2种,一:每回路,a——>b 二:形成回路,a——>…——>a。对于整副图
(每一块块组合而成),等于 :第一块奇数点/2+第二块奇数点/2+…….,最后得,图的总奇数点/2。

需要考虑:
①若连通分量是一个单独的点,没有边,需要0笔画。
②若连通分量是一个欧拉图或者半欧拉图,则需要1笔。
③若连通分量是一个非(半)欧拉图,则需要的笔画=该图中奇度数的点的数量/2
总之笔划数 = 奇度数%2 + 欧拉回路数。

我们用数组st[i]来记录i的度数。 用gen[i]来记录以i为根的连通分量的点的个数,
当gen[i]==0时表示i不是连通分量的根,
当gen[i]==1时,表示该连通分量是一个孤立的点。
这两种情况下笔画都不增加。

code :

#include <iostream>
#include <bits/stdc++.h>
using namespace std;
int pre[50001],st[50001],gen[50001],num[50001];
int Find(int x)    //查找根节点
{
    if (pre[x]==x)    //自己是自己的根节点
        return x;   
    else
        return pre[x] = Find(pre[x]);
}
void mix(int a, int b)   //使两条路相关的路全部连通
{
    int fa,fb;
    fa = Find(a);   //找个点的根节点
    fb = Find(b);
    if (fa!=fb)     //根节点不通 强行 将一方当做根节点跟另一方
        pre[fa] = fb;
}
int main()
{
    int n,m;
    while (~scanf("%d%d",&n,&m))
    {
        memset(pre,0,sizeof(pre));
        memset(st,0,sizeof(st));
        memset(gen,0,sizeof(gen));
        memset(num,0,sizeof(num));

        for (int i=1; i<=n; i++){  //自己为自己的根节点
            pre[i] = i;
        }
        while (m--)
        {
            int a,b;
            cin>>a>>b;
            st[a]++;    //统计a,b节点分别与多少节点项链
            st[b]++;
            mix(a,b);   //使a,b节点通路
        }
        for (int i=1; i<=n; i++){
            gen[Find(i)]++;      //统计以 k为根的个数  k取1~n
            if (st[i]%2)
                num[Find(i)]++;   //  统计根节点为 奇节点的个数
        }
        int sum=0;
        for (int i=1; i<=n; i++){
            if (gen[i]>1&&num[i]==0)   //是(半)连通图
                sum++;
            if (gen[i]>1&&num[i]>0)
                sum += num[i]/2;
        }
        cout<<sum<<endl;
    }
    return 0;
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值