HDU-3535 AreYouBusy(多组背包)

AreYouBusy

Time Limit : 2000/1000ms (Java/Other) Memory Limit : 32768/32768K (Java/Other)
Total Submission(s) : 25 Accepted Submission(s) : 17
Problem Description
Happy New Term!
As having become a junior, xiaoA recognizes that there is not much time for her to AC problems, because there are some other things for her to do, which makes her nearly mad.
What’s more, her boss tells her that for some sets of duties, she must choose at least one job to do, but for some sets of things, she can only choose at most one to do, which is meaningless to the boss. And for others, she can do of her will. We just define the things that she can choose as “jobs”. A job takes time , and gives xiaoA some points of happiness (which means that she is always willing to do the jobs).So can you choose the best sets of them to give her the maximum points of happiness and also to be a good junior(which means that she should follow the boss’s advice)?

Input
There are several test cases, each test case begins with two integers n and T (0<=n,T<=100) , n sets of jobs for you to choose and T minutes for her to do them. Follows are n sets of description, each of which starts with two integers m and s ( 0< m <=100), there are m jobs in this set , and the set type is s, (0 stands for the sets that should choose at least 1 job to do, 1 for the sets that should choose at most 1 , and 2 for the one you can choose freely).then m pairs of integers ci,gi follows (0<=ci,gi<=100), means the ith job cost ci minutes to finish and gi points of happiness can be gained by finishing it. One job can be done only once.

Output
One line for each test case contains the maximum points of happiness we can choose from all jobs .if she can’t finish what her boss want, just output -1 .

Sample Input
3 3
2 1
2 5
3 8
2 0
1 0
2 1
3 2
4 3
2 1
1 1

3 4
2 1
2 5
3 8
2 0
1 1
2 8
3 2
4 4
2 1
1 1

1 1
1 0
2 1

5 3
2 0
1 0
2 1
2 0
2 2
1 1
2 0
3 2
2 1
2 1
1 5
2 8
3 2
3 8
4 9
5 10

Sample Output
5
13
-1
-1

题意:
给你n个工作集合,给你T的时间去做它们。给你m和s,说明这个工作集合有m件事可以做,它们是s类的工作集合(s=0,1,2,s=0说明这m件事中最少得做一件,s=1说明这m件事中最多只能做一件,s=2说明这m件事你可以做也可以不做)。再给你ci和gi代表你做这件事要用ci的时间,能获得gi的快乐值。求在T的时间内你能获得的最大快乐值。

这道题做的很。。。。。 感觉自己读题分析题时候 理解不了 后来查了题解, 还是没办法理解为什么这样写。持续了2天 慢慢看才把坑给填平

分析:
三种状态 当为 0 ,1, 2 是

0: 该集合至少选一件 , 既然是至少一件,简单思考一下, 也不能指定那一件在哪, 那么我们就 就有了3种状态:1. 上次拿了 2. 这次没拿 3.这次拿了, 这三种状态去确保 我们至少有一件。
dp[i][k]=max(dp[i][k],dp[i-1][k-cost[j]]+val[k],dp[i][k-cost[j]]+val[j] )

1: 改集合至多选1件, 只能从上一层的结果dp[i-1]来更新dp[i]了.

2:随便选 就是简单01 背包了

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>

using namespace std;

const int INF=0x3f3f3f3f;

int n,m,sum;
int w[110],p[110];
int dp[110][110];

int main()
{
    while(~scanf("%d%d",&n,&sum))
    {
        memset(dp,0,sizeof(dp));
        int i,j,k,g;
        for(i=1; i<=n; i++)
        {
            scanf("%d%d",&m,&g);
            for(k=1; k<=m; k++)
                scanf("%d%d",&w[k],&p[k]);
            if(g==0)//至少选1个的01背包问题  
            {
                for(j=0; j<=sum; j++) //当前组初始化
                    dp[i][j]=-INF;
                for(k=1; k<=m; k++)
                    for(j=sum; j>=w[k]; j--)
                        dp[i][j]=max(dp[i][j],max(dp[i][j-w[k]]+p[k],dp[i-1][j-w[k]]+p[k]));
            }
            else if(g==1)//至多选1个的背包问题  
            {
                for(j=0; j<=sum; j++) //当前组初始化
                    dp[i][j]=dp[i-1][j];
                for(k=1; k<=m; k++)
                    for(j=sum; j>=w[k]; j--)
                        dp[i][j]=max(dp[i][j],dp[i-1][j-w[k]]+p[k]);
            }
            else if(g==2)/随便选的01背包问题  
            {
                for(j=0; j<=sum; j++) //当前组初始化
                    dp[i][j]=dp[i-1][j];
                for(k=1; k<=m; k++)
                    for(j=sum; j>=w[k]; j--)
                        dp[i][j]=max(dp[i][j],dp[i][j-w[k]]+p[k]);
            }
        }
        dp[n][sum]=max(dp[n][sum],-1);  //没有完成任务的值都为负的,做输出调整,输出-1
        printf("%d\n",dp[n][sum]);
    }
    return 0;
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值