第五届河南省程序设计大赛nyoj545Metric Matrice(java 类goto语句)

Metric Matrice

时间限制: 1000 ms  |  内存限制: 65535 KB
难度:1
描述

Given as input a square distance matrix, where a[i][j] is the distance between point i and point j, determine if the distance matrix is "a  metric" or not.

A distance matrix a[i][j] is a metric if and only if

    1.  a[i][i] = 0

    2, a[i][j]> 0  if i != j

    3.  a[i][j] = a[j][i]

    4.  a[i][j] + a[j][k] >= a[i][k]  i ¹ j ¹ k

输入
The first line of input gives a single integer, 1 ≤ N ≤ 5, the number of test cases. Then follow, for each test case,
* Line 1: One integer, N, the rows and number of columns, 2 <= N <= 30
* Line 2..N+1: N lines, each with N space-separated integers
(-32000 <=each integer <= 32000).
输出
Output for each test case , a single line with a single digit, which is the lowest digit of the possible facts on this list:
* 0: The matrix is a metric
* 1: The matrix is not a metric, it violates rule 1 above
* 2: The matrix is not a metric, it violates rule 2 above
* 3: The matrix is not a metric, it violates rule 3 above
* 4: The matrix is not a metric, it violates rule 4 above
样例输入
240 1 2 31 0 1 22 1 0 13 2 1 020 32 0
样例输出
03
来源
第五届河南省程序设计大赛
上传者
rihkddd



import java.util.Scanner;

public class nyoj545Metric_Matrice {

	public static void main(String[] args) {
		int[][]a;
		int n;
		Scanner sc = new Scanner(System.in);
		int ans=0;
		loop:for(int N=sc.nextInt();N-->0;System.out.println(ans)){
			n=sc.nextInt();
			a=new int[n][n];	
			for(int i=0;i<n;i++)
				for(int j=0;j<n;j++)
					a[i][j]=sc.nextInt();
			
			for(int i=0;i<n;i++)			
				for(int j=0;j<n;j++){					 
					if(a[i][i]!=0){ 						  
						ans=1;continue loop ;
					}if(i!=j&&a[i][j]<=0){						
						ans=2;continue loop;
					}if(a[i][j]!=a[j][i]){						
						ans=3;continue loop;
					}					
				}		
			
			for(int i=0;i<n;i++)				
			   for(int j=0;j<n;j++)	
		         for(int k=0;k<n;k++)//该条件不可嵌套在上面代码之中!!!
					 if((i!=j && j!=k && i!=k)&& ( a[i][j] + a[j][k] < a[i][k] )){
				          ans=4; continue loop;     					          
			          }			
		ans=0;							
		}
	}
}



return做法:


import java.util.Scanner;

public class Main {

	private static int[][] array = null;
	private static int cases, i, j, n;
	private static Scanner in = new Scanner(System.in);

	public static void main(String[] args) {
		// TODO Auto-generated method stub
		cases = in.nextInt();
		while (cases-- > 0) {
			n = in.nextInt();
			array = new int[n][n];
			for (i = 0; i < n; ++i) {
				for (j = 0; j < n; ++j) {
					array[i][j] = in.nextInt();
				}
			}
			System.out.println(solve(array));

		}
	}

	private static int solve(int[][] array) {

		for (int i = 0; i < array.length; ++i) {
			if (array[i][i] != 0) {
				return 1;
			}
			for (int j = i + 1; j < array[i].length; ++j) {
				if (array[i][j] <= 0 || array[j][i] <= 0) {
					return 2;
				}
				if (array[i][j] != array[j][i]) {
					return 3;
				}
			}
		}
		for (int i = 0; i < array.length; ++i) {
			for (int j = 0; j < array[i].length; ++j) {
				if (j == i) {
					continue;
				} else {
					for (int k = 0; k < array.length; ++k) {
						if (k == i || k == j) {
							continue;
						} else {
							if (array[i][k] + array[k][j] < array[i][j]) {
								return 4;
							}
						}
					}
				}
			}
		}

		return 0;
	}
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值