hdu-1518-Square

Square

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 6042    Accepted Submission(s): 1940


Problem Description
Given a set of sticks of various lengths, is it possible to join them end-to-end to form a square?
 

Input
The first line of input contains N, the number of test cases. Each test case begins with an integer 4 <= M <= 20, the number of sticks. M integers follow; each gives the length of a stick - an integer between 1 and 10,000.
 

Output
For each case, output a line containing "yes" if is is possible to form a square; otherwise output "no".
 

Sample Input
  
  
3 4 1 1 1 1 5 10 20 30 40 50 8 1 7 2 6 4 4 3 5
 

Sample Output
  
  
yes no yes
 

Source
 

Recommend
LL
 
package 暑期培训_2013_08_04;

import java.util.Arrays;
import java.util.Comparator;
import java.util.Scanner;

public class Square_1518_201308071747{
    private static boolean vis[],ok=true;
    private static Integer a[],edge=0,n;
    public static void main(String[] args) {
        Scanner input=new Scanner(System.in);
        int N=input.nextInt();
        while(N-->0){
            n=input.nextInt();
            Init();
            int max=0;
            for(int i=0;i<n;++i){
                a[i]=input.nextInt();
                max+=a[i];
            }//求平均边长
            edge=max>>2;
            Arrays.sort(a,new Comparator<Integer>(){    //从大到小排序
                public int compare(Integer o1, Integer o2){
                    return o2-o1;
                }
            });
            if(max%4==0&&edge>=a[0]){//是否是整除4,是否最大边超过平均边长
                dfs(0,0,0);
                if(ok)
                    System.out.println("yes");
                else
                    System.out.println("no");
            }
            else{
                System.out.println("no");
            }
        }
    }
    private static void Init() {//初始化
        edge=0;
        ok=false;
        a=new Integer[n];
        vis=new boolean[n];
    }/*cur_edge:当前组合的边长长度(可能未组合完毕,未达到平均边长)、num:组和好的边数,i:数组中用到的第i个数*/ 
    private static void dfs(int cur_edge, int num,int i) {
        if(ok)
            return;
        if(num==3){
            ok=true;
            return;//结束递归的方法  return  ;
        }
        if(cur_edge==edge){
            dfs(0,num+1,num+1);//组合成功后,考虑下一个
        }
        for(;i<n;i++){//依次找,并匹配是否满足条件、i的值在每次递归中改变,判断i的下一个
            if(!vis[i]){//查找过得,标记下来
                if(cur_edge+a[i]<=edge){//
                    vis[i]=true;
                        dfs(cur_edge+a[i],num,i+1);//
                    vis[i]=false;
                }
            }
        }
    }
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值