poj-1011-Sticks(广搜bfs)

                                            Sticks
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 110765 Accepted: 25419

Description

George took sticks of the same length and cut them randomly until all parts became at most 50 units long. Now he wants to return sticks to the original state, but he forgot how many sticks he had originally and how long they were originally. Please help him and design a program which computes the smallest possible original length of those sticks. All lengths expressed in units are integers greater than zero.

Input

The input contains blocks of 2 lines. The first line contains the number of sticks parts after cutting, there are at most 64 sticks. The second line contains the lengths of those parts separated by the space. The last line of the file contains zero.

Output

The output should contains the smallest possible length of original sticks, one per line.

Sample Input

9
5 2 1 5 2 1 5 2 1
4
1 2 3 4
0

Sample Output

6
5

Source

 
 
package 暑期培训_2013_08_04;

import java.util.Arrays;
import java.util.Comparator;
import java.util.Scanner;

public class poj_1011_Sticks_201308140952 {

	/**
	 * @param args
	 *///1983210400 1011 Accepted 5536K 219MS Java 1523B 2013-08-14 11:06:11 
	private static Integer[] a;
	private static int len,N;
	private static int[] b;

	private static boolean f(int num, int left) {
		// TODO Auto-generated method stub
		if (num == 0 && left == 0)
			return true;
		if (left == 0)
			left = len;
		for (int i = 0; i < N; i++) {
			if (b[i] == 0 && a[i] <= left) {
				if (i > 0 && a[i] == a[i - 1] && b[i - 1] == 0)
					continue;
				b[i] = 1;
				if (f(num - 1, left - a[i]))
					return true;
				else {
					b[i] = 0;
					if (left == len || left == a[i])
						return false;
				}
			}
		}
		return false;
	}

	public static void main(String[] args) {
		// TODO Auto-generated method stub

		Scanner sc = new Scanner(System.in);

		while (sc.hasNext()) {
			 N = sc.nextInt();

			if (N == 0)
				break;
			int total = 0;
			a = new Integer[N];
			for (int i = 0; i < N; i++) {
				a[i] = sc.nextInt();
				total += a[i];
			}

			Arrays.sort(a, new Comparator<Integer>() {// 从大到小排序

						@Override
						public int compare(Integer o1, Integer o2) {
							return o2 - o1;
						}
					});
			// 小于总长度一半时
			for (len = a[0]; len <= total / 2; len++) {
				if (total % len == 0) {
					b = new int[N];
					if (f(N, len)) {
						System.out.println(len);
						break;
					}
				}
			}
			if (len > total / 2) // 大于时,输出总长度total
				System.out.println(total);
		}
	}
}

 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值